Bug 31053 - Custom label renderer does not draw graphics on the Label using CGContext
Summary: Custom label renderer does not draw graphics on the Label using CGContext
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: 1.4.2
Hardware: PC Mac OS
: High normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-06-12 03:47 UTC by Prashant Cholachagudda
Modified: 2015-07-22 05:43 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Prashant Cholachagudda 2015-06-12 03:47:14 UTC
Customer has a custom renderer where he is drawing the strike through line, and it does not render for some items in the listview.
Test case: https://gist.github.com/prashantvc/3a0ab3de9c21469661f4

See: Attached screenshot
Comment 2 Rui Marinho 2015-06-15 11:39:12 UTC
Thank you for taking the time to submit the bug. We tried to reproduce the issue you reported but were unable given the description. 
I have created a label and a custom renderer and ir renderes as expected.
If you could please attach a reproduction to the bug by starting with a clean Xamarin.Forms project and adding just the code necessary to demonstrate the issue we would very much appreciate it.

Warm regards,
Xamarin Forms Team
Comment 5 Rui Marinho 2015-07-21 10:08:49 UTC
I updated to XF 1.4.3.6376 and all the items of the list have the strike through line , so it seems resolved.

Please verify.
Comment 6 r.baldew 2015-07-22 04:51:05 UTC
Hi Rui,

After updating to XF 1.4.3.6376 the problem in now resolved.

Thanks for your support!

Regards,

Ravi