Bug 31049 - GroupHeaderTemplate cells render over item cells
Summary: GroupHeaderTemplate cells render over item cells
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: 1.4.3
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-06-11 23:14 UTC by Cody Beyer (MSFT)
Modified: 2015-07-02 14:46 UTC (History)
4 users (show)

Tags: ac listview grouping
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Cody Beyer (MSFT) 2015-06-11 23:14:49 UTC
### Description

The linked sample app uses a GroupHeaderTemplate and an ItemTemplate. The GroupHeader is larger and overrides the Items

### Sample

https://www.dropbox.com/s/iz1f4r6o752c2hk/ListViewSample.zip?dl=0

### Steps to Reproduce

1. Download linked sample
2. Deploy to iOS Simulator

### Expected Results

The header should be sanely sized and green: https://www.dropbox.com/s/n3zcxwxx2rwo353/Screenshot%202015-06-11%2020.14.01.png?dl=0

### Actual Results

The sizes are all wrong. Its still green, though: https://www.dropbox.com/s/lr94ttwtqvwe53j/Screenshot%202015-06-11%2020.12.46.png?dl=0

### Versions

=== Xamarin Studio ===

Version 5.9.4 (build 5)
Installation UUID: fc65f77a-6bee-473f-8adb-6b27b14a8197
Runtime:
	Mono 4.0.2 ((detached/198235d)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400020004

=== Apple Developer Tools ===

Xcode 6.3.2 (7718)
Build 6D2105

=== Xamarin.iOS ===

Version: 8.10.2.17 (Business Edition)
Hash: 03fdc45
Branch: master
Build date: 2015-06-09 07:44:00-0400

=== Xamarin.Mac ===

Version: 2.0.2.17 (Business Edition)

=== Xamarin.Android ===

Version: 5.1.4.8 (Business Edition)
Android SDK: /Users/codybeyer/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Build Information ===

Release ID: 509040005
Git revision: 8010a90f6e246b32364e3fb46ef2c9d1be9c9a2b
Build date: 2015-06-08 16:52:06-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

=== Operating System ===

Mac OS X 10.10.3
Darwin Codys-MacBook-Pro.local 14.3.0 Darwin Kernel Version 14.3.0
    Mon Mar 23 11:59:05 PDT 2015
    root:xnu-2782.20.48~5/RELEASE_X86_64 x86_64
Comment 1 tim.ahrentlov 2015-06-26 06:56:29 UTC
Will this be fixed for 1.4.4?
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2015-06-26 20:49:39 UTC
## Regression status: regression between Xamarin.Forms 1.4.2.6359 and Xamarin.Forms 1.4.3.6358-pre2 that is already fixed?

GOOD: Xamarin.Forms 1.4.2.6359 
BAD:  Xamarin.Forms 1.4.3.6358-pre2
GOOD: Xamarin.Forms 1.4.3.6364-pre3


According to my brief tests, the behavior appears to be restored to the 1.4.2.6359 behavior as of 1.4.3.6364-pre3.


-Brendan
Xamarin Customer Support
Comment 3 Brendan Zagaeski (Xamarin Team, assistant) 2015-06-26 21:00:46 UTC
For reference, there was some additional context about the GroupHeaderTemplate problem in the 1.4.3-pre2 release thread: http://forums.xamarin.com/discussion/comment/118150/#Comment_118150.

That comment mentions Bug 28364 as having been fixed in 1.4.3. For thoroughness, I double-checked Bug 28364 on 1.4.3-pre3, and it still behaves correctly.
Comment 4 tim.ahrentlov 2015-06-27 03:49:09 UTC
Thanks Brendan. I'll check when 1.4.3 hits stable and the nuget will install.
Comment 5 Brendan Zagaeski (Xamarin Team, assistant) 2015-07-02 14:46:43 UTC
I double-checked the test case today using the new Xamarin.Forms 1.4.3.6374 stable release in Xamarin Studio on Mac.

The behavior is restored to the old "good" behavior of 1.4.2.6359, so I will mark this bug as fixed for now.

Feel free to reply if I have missed any detail in testing this behavior. In particular, let us know if the test case from comment 0 does still demonstrate a problem on XF 1.4.3.6374. Thanks!