Bug 3092 - MonoDevelop crashes when attempting to load a .xib file
Summary: MonoDevelop crashes when attempting to load a .xib file
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- critical
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-01-26 14:08 UTC by Zane
Modified: 2012-03-28 13:16 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Zane 2012-01-26 14:08:09 UTC
Current Behavior: When trying to open a Single View Solution's .xib file MonoDevelop gives me an error.

Expected Behavior: I expect MonoDevelop to open the .xib file with XCode.

Steps to Reproduce:
1. Create a new Single View iPhone solution in MonoDevelop.
2. Click the solution's iPhoneViewController.xib file in the lefthand pane of MonoDevelop.

MonoDevelop version: 2.8.6.3
Runtime: Mono 2.10.8 (tarball Mon Dec 19 17:43:18 EST 2011)
Apple Developer Tools:
	 Xcode 4.2.1 (834)
	 Build 4D502
Monotouch: 5.0.4 


Error Message:
System.Exception: Did not get project info
  at MonoDevelop.MacDev.XcodeSyncing.XcodeProjectTracker.UpdateTypes (IProgressMonitor monitor, Boolean force) [0x00029] in /Users/builder/data/lanes/monodevelop-mac-2.8.6.3/f4289daf/source/monodevelop/main/src/addins/MonoDevelop.MacDev/XcodeSyncing/XcodeProjectTracker.cs:302
Comment 1 Jeffrey Stedfast 2012-01-26 14:15:22 UTC
This suggests that either MonoDevelop failed to get the Dom for the project or else the Dom could not resolve the NSObject type.

Can you reproduce this reliably?

I wonder if it is some sort of race... like maybe MonoDevelop hadn't finished parsing the sources for the project to generate a Dom?
Comment 3 Jeffrey Stedfast 2012-03-28 13:16:03 UTC
the race condition for this should be fixed in MonoDevelop 2.8.8.3+