Bug 30737 - UI Tests documentation incorrectly states how to use Marked for Xamarin.Forms
Summary: UI Tests documentation incorrectly states how to use Marked for Xamarin.Forms
Status: RESOLVED INVALID
Alias: None
Product: Documentation
Classification: Xamarin
Component: Multi-Platform ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: bryan costanich
URL:
Depends on:
Blocks:
 
Reported: 2015-06-03 12:40 UTC by Adam Kemp
Modified: 2015-06-05 11:47 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Adam Kemp 2015-06-03 12:40:30 UTC
See this bug:
https://bugzilla.xamarin.com/show_bug.cgi?id=30735

The documentation (http://developer.xamarin.com/guides/cross-platform/xamarin-forms/uitest-and-test-cloud/) claims that you can use StyleId for Marked queries. That doesn't actually work. I don't think anything really does work, which is why I filed a bug against Xamarin.Forms as well. Until that other bug is fixed the documentation should not claim that you can do this, and once that bug is fixed the documentation should cover whatever the correct technique actually is.
Comment 1 Adam Kemp 2015-06-05 11:47:01 UTC
It turns out I missed an important part of the documentation. See this bug:

https://bugzilla.xamarin.com/show_bug.cgi?id=30735