Bug 30676 - SystemInformation.PowerStatus.BatteryLifePercent returns the wrong result
Summary: SystemInformation.PowerStatus.BatteryLifePercent returns the wrong result
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: Windows.Forms ()
Version: 4.0.0
Hardware: PC Windows
: --- normal
Target Milestone: Community
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-06-02 12:10 UTC by Andrius Lukoševičius
Modified: 2017-09-01 11:56 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
A simple project to display the problem. (12.88 KB, application/octet-stream)
2015-06-02 12:10 UTC, Andrius Lukoševičius
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 30676 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Andrius Lukoševičius 2015-06-02 12:10:57 UTC
Created attachment 11431 [details]
A simple project to display the problem.

SystemInformation.PowerStatus.BatteryLifePercent seems to return random results:
if the battery is full it returns 1.00 as it should, however if it is not it either returns a seemingly random value or the time remaining until battery is empty. The latter seems to happen more often as the battery level gets lower.
I've submitted a simple project to display the problem.