Bug 30662 - On editing Text of Button, it gets deleted.
Summary: On editing Text of Button, it gets deleted.
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android Designer ()
Version: 3.11 (C5)
Hardware: PC Windows
: Normal normal
Target Milestone: 4.0.0 (C6)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-06-02 07:08 UTC by asimk
Modified: 2015-08-06 06:43 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 Peter Collins 2015-06-02 10:43:25 UTC
This looks to be rather similar to Bug #20505, except rather than the widget being deleted immediately after pressing the delete key, it isn't deleted until you press enter or "save" the deletion edit that was made. I was also able to reproduce this on the current stable 3.11.458 with Platform Tools 24.2.

I'm not sure if the core issue is the same here and if this should be resolved as a duplciate of Bug #20505
Comment 2 Peter Collins 2015-06-02 12:16:08 UTC
Moving to C6 milestone as this behavior does not appear to be a regression, and as per Bug #20505.
Comment 3 Alan McGovern 2015-07-31 11:53:09 UTC
Seems to be fixed in master
Comment 4 asimk 2015-08-06 06:43:29 UTC
I have checked this issue and observed that it is working fine. Hence closing this issue.

Screencast: http://www.screencast.com/t/bhxUi0Sy

Environment Info:
Microsoft Visual Studio Professional 2012
Version 11.0.61030.00 Update 4
Microsoft .NET Framework
Version 4.6.00057

Installed Version: Professional

Xamarin   5.1.324.0 (e3e96ff)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   5.1.99.548 (33e00ac69c778e49ae17297daef0830bdb7188d6)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.iOS   8.13.0.0 (66a05442290ad5415d447e3613586cf09322bffd)
Visual Studio extension to enable development for Xamarin.iOS.