Bug 30638 - [Master]Application is getting crashed when we run xam.mac template application in release mode
Summary: [Master]Application is getting crashed when we run xam.mac template applicati...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Other ()
Version: Master
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Chris Hamons
URL:
Depends on:
Blocks:
 
Reported: 2015-06-01 13:52 UTC by asimk
Modified: 2015-07-20 13:39 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 Chris Hamons 2015-06-02 12:49:33 UTC
Wait,     Mono 4.3.0 (explicit/54e8010)?

Could you test this against the mono that we shipped in Beta? We didn't ship 4.3?
Comment 2 Rajneesh Kumar 2015-07-20 13:39:17 UTC
Hi Chris,

I have checked this issue with the latest master builds and observed that this issue no longer exist with these builds. I am able to run the application in the release mode successfully. Please refer the screencast: http://www.screencast.com/t/apeJOWYn34p

This issue seems fixed to me, also it is working fine , hence as of now I am closing this issue.

Thanks..!

Environment Info:

=== Xamarin Studio ===

Version 5.10 (build 419)
Installation UUID: 011d70a5-dede-428b-ab04-ef451c2e539d
Runtime:
	Mono 4.3.0 (explicit/b9cff43)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 403000489

=== Xamarin.Profiler ===

Version: 0.0.0.0
Location: /Applications/XamarinProfiler.Mac.app/Contents/MacOS/XamarinProfiler.Mac

=== Apple Developer Tools ===

Xcode 6.2 (6776)
Build 6C131e

=== Xamarin.Mac ===

Version: 2.3.0.0 (Business Edition)

=== Xamarin.Android ===

Version: 5.1.99.493 (Business Edition)
Android SDK: /Users/MM/Desktop/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		5.1    (API level 22)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin Android Player ===

Version: 0.3.4
Location: /Applications/Xamarin Android Player.app

=== Xamarin.iOS ===

Version: 8.13.0.0 (Business Edition)
Hash: 3a64d53
Branch: master
Build date: 2015-07-17 16:55:49-0400

=== Build Information ===

Release ID: 510000419
Git revision: 527e446c9005cb1ab173258a823399afb7770fc8
Build date: 2015-07-19 15:53:40-04
Xamarin addins: dcaf5dc1c5b9c341a9038313f3e6c6615b2e4cff
Build lane: monodevelop-lion-master

=== Operating System ===

Mac OS X 10.9.5
Darwin MacMini.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64