Bug 30412 - Images in ListView delayed until some thread finishes
Summary: Images in ListView delayed until some thread finishes
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 1.4.3
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-05-25 11:57 UTC by Michał Mazur
Modified: 2016-04-08 19:58 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
App demonstrating the bug (200.45 KB, application/octet-stream)
2015-05-25 12:00 UTC, Michał Mazur
Details
Simplified app demonstrating the bug (31.53 KB, application/octet-stream)
2015-05-27 05:56 UTC, Michał Mazur
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Michał Mazur 2015-05-25 11:57:45 UTC
Attached sample app.

1. Images are loaded correctly, except during a Task/Thread started by Insights (web service connection ?)
2. App is still responsive, only the images are not loaded during the task
3. Though app does not respond properly to orientation change during the task (freezes until it finishes)
4. Disabling Insights causes app to work properly
Comment 1 Michał Mazur 2015-05-25 12:00:10 UTC
Created attachment 11317 [details]
App demonstrating the bug
Comment 2 Chris King 2015-05-26 15:25:28 UTC
We'd be happy to help you resolve this issue. Please help us by attaching a reduced reproduction to the bug by starting with a clean Xamarin.Forms project and adding just the code necessary to demonstrate the issue. 

Warm regards,
Xamarin Forms Team
Comment 3 Michał Mazur 2015-05-27 05:56:01 UTC
Created attachment 11355 [details]
Simplified app demonstrating the bug

App contains a simple list of items and a button to refresh the list.
Depending on some task (I believe it is being started by Insights) images in the list items are not loading until the task finishes. Images will not appear even without refreshing the list - it is enough to scroll the list back and forth while the task is running to see that images are not showing on the recycled cells.

I can't make app much simpler.

Thanks,
Michal
Comment 4 leankitryan 2015-05-27 14:45:33 UTC
We seeing this as well. It appears to be a duplicate of this issue which is a bit more thorough: https://bugzilla.xamarin.com/show_bug.cgi?id=30333

We rolled back to insights 1.9.0.107 which does not seem to have any thread blocking issues.
Comment 5 Jason Smith [MSFT] 2016-04-08 19:58:04 UTC
Duplicate