Bug 30393 - RaiseChild does not operate as expected in < API 19
Summary: RaiseChild does not operate as expected in < API 19
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 1.4.4
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-05-24 18:34 UTC by Cody Beyer (MSFT)
Modified: 2017-06-19 20:34 UTC (History)
3 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
a (6.25 MB, application/x-zip-compressed)
2015-05-27 19:20 UTC, Chris King
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Cody Beyer (MSFT) 2015-05-24 18:34:49 UTC
### Description

The following sample app demonstrates an issue where clicking a button to raise a child view does not correctly raise said view

### Sample

https://www.dropbox.com/s/y1ym0sqzqq8cg7p/XamarinBug.zip?dl=0

### Steps to Reproduce

1. Download and open test app
2. Deploy to Android Player API 16
3. Click the "Click Me" Button

### Expected Behavior

Blue section should envelope the red section (such as: https://www.dropbox.com/s/8x9eyqlr5vu1tv0/BlueClick.mov?dl=0)

### Actual Behavior

The blue box does not envelope the red section (such as: https://www.dropbox.com/s/o8157k7ibo2ggg4/BadBlueBox.mov?dl=0)

### Version

=== Xamarin Studio ===

Version 5.9.2 (build 2)
Installation UUID: 061f61cf-c366-4da7-b3c9-31033d0fc883
Runtime:
	Mono 4.0.1 ((detached/11b5830)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400010043

=== Apple Developer Tools ===

Xcode 6.3.2 (7718)
Build 6D2105

=== Xamarin.iOS ===

Version: 8.10.1.59 (Business Edition)
Hash: 13d1cdc
Branch: master
Build date: 2015-05-18 22:54:57-0400

=== Xamarin.Android ===

Version: 5.1.2.0 (Business Edition)
Android SDK: /Users/beyerc/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.0.1.59 (Business Edition)

=== Build Information ===

Release ID: 509020002
Git revision: 43735a4b905b571f69cf9428a3ea7b52aef55476
Build date: 2015-05-18 09:38:12-04
Xamarin addins: ab18ddff45f507ed74f36c2b65df9aee22e28a56

=== Operating System ===

Mac OS X 10.10.3
Darwin Codys-MacBook-Pro.local 14.3.0 Darwin Kernel Version 14.3.0
    Mon Mar 23 11:59:05 PDT 2015
    root:xnu-2782.20.48~5/RELEASE_X86_64 x86_64
Comment 1 Chris King 2015-05-26 15:35:23 UTC
I downloaded the attached repro but it didn't have a solution file. Please help us by attaching a reduced reproduction to the bug by starting with a clean Xamarin.Forms project and adding just the code necessary to demonstrate the issue. 

Warm regards,
Xamarin Forms Team
Comment 2 Chris King 2015-05-27 19:20:50 UTC
Created attachment 11363 [details]
a
Comment 4 Chris King 2015-05-27 19:29:41 UTC
Confirmed
Comment 5 Jonck 2017-02-24 13:17:23 UTC
Whats the progress on this (if any?). It's been over a year and a half since this bug was listed. 
I have made heavy use of the RaiseChild and LowerChild methods and just recently I've encountered this bug as well. It's fairly critical to my application.
Comment 6 Jason Smith [MSFT] 2017-06-19 20:34:52 UTC
Works fine in latest version of Xamarin.Forms. Reproduction no longer fails, not sure which version fixed it.