Bug 30384 - IsEnabled = false on page does not disable controls on page
Summary: IsEnabled = false on page does not disable controls on page
Status: RESOLVED NOT_ON_ROADMAP
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.4.3
Hardware: PC Windows
: Normal enhancement
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-05-23 12:54 UTC by John Hardman
Modified: 2018-04-10 12:43 UTC (History)
7 users (show)

Tags: ngf
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_ON_ROADMAP

Description John Hardman 2015-05-23 12:54:33 UTC
IsEnabled = false on a page does not disable controls on the page. I would expect setting IsEnabled on a page to have an effect on all of the controls on the page.
Comment 1 adrianknight89 2016-01-30 23:08:48 UTC
i agree. This should be a new feature.
Comment 2 Jason Smith [MSFT] 2016-04-08 19:52:42 UTC
Thank you for your report. At this time there are no plans to implement any changes around this issue.

Warm regards,
Xamarin Forms Team
Comment 3 develop 2018-04-10 12:43:39 UTC
This issue might have actually been resolved. Using Xamarin.Forms 2.5.1.444934 disabling a page seems to disable all of the elements on it. I've tested this on UWP and Android, while I know iOS should natively behave correctly.