Bug 30286 - Crash during app deployment: string.ToLowerInvariant()
Summary: Crash during app deployment: string.ToLowerInvariant()
Status: RESOLVED INVALID
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler ()
Version: 5.2
Hardware: PC Mac OS
: Highest blocker
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2015-05-20 19:57 UTC by cfraz89
Modified: 2015-05-22 03:33 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Stacktrace (1.69 KB, application/octet-stream)
2015-05-20 19:57 UTC, cfraz89
Details
Debug window screenshot (210.51 KB, image/png)
2015-05-20 19:57 UTC, cfraz89
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description cfraz89 2015-05-20 19:57:07 UTC
Created attachment 11269 [details]
Stacktrace

Using Xamarin Android 5.1.(2?) beta channel, our app builds ok, but crashes immediately. on deployment.

Locals window lists this as "AAMI", exception type TypeInitializationException.

Stacktrace attached.
Comment 1 cfraz89 2015-05-20 19:57:53 UTC
Created attachment 11270 [details]
Debug window screenshot
Comment 2 Peter Collins 2015-05-21 13:42:28 UTC
I think we'll need some more information to help track this down if possible.

What is the target device and locale you're seeing this error on?

Is this a new error that you're now seeing with the latest Beta release (5.1.2.0)? Or do you also see the crash when using the current stable version 5.1.1.0?

Finally, would it be possible for you attach a small project or code snippet which reproduces this crash?
Comment 3 cfraz89 2015-05-21 21:42:21 UTC
Hey,

After cleaning out the project en masse (deleting bin and obj folders), and toggling the shared runtime option on and off, this issue no longer occurs, and I can no longer reproduce it, the app will run with shared runtime off.

However app now does not run with Shared Runtime option on, with minimal debug output. Using Genymotion emulator, Android 5.0. Have attached sample app that won't run. Should I raise this as a separate issue?
Comment 4 cfraz89 2015-05-21 21:58:03 UTC
Scrap that, the original issue is happening again on our codebase, this time on a Genymotion 4.1.1 emulator.

Having difficulty putting together a small project that encounters the same problem. I'll keep trying.
Comment 5 cfraz89 2015-05-21 22:22:14 UTC
5.1.1.0 Had another issue which prevents the app compiling - https://bugzilla.xamarin.com/show_bug.cgi?id=29568

Hence jumping to beta channel in an attempt to keep the app running.
Comment 6 cfraz89 2015-05-22 03:33:17 UTC
Ok, seems to have stabilised now with a reinstall of Xamarin. Maybe upgrade
process went pear-shaped silently. Sorry for the false bug, will close off.
Comment 7 cfraz89 2015-05-22 03:33:55 UTC
Closed