Bug 30252 - Not able to open "recent project" if solution path contains "%20"
Summary: Not able to open "recent project" if solution path contains "%20"
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Shell ()
Version: 5.9
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: 5.10 (C6)
Assignee: Bugzilla
URL:
: 11028 ()
Depends on:
Blocks:
 
Reported: 2015-05-20 03:40 UTC by marc
Modified: 2015-10-13 13:40 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description marc 2015-05-20 03:40:41 UTC
When trying to open a "recent solution" from start page (left panel), I am shown an error dialog saying: "File not found: [...]".

The solution name contains a whitespace "For example.sln".
Comment 1 Matt Ward 2015-05-21 07:48:25 UTC
I am unable to reproduce this. I tried a solution filename with a space in it and also a solution filename with a space in it inside a directory which had a space in it. Both of these opened in Xamarin Studio 5.9.1 when they were selected from the Xamarin Studio start page.

Would you be able to provide repro steps and attach the IDE logs to the bug report?
Comment 2 marc 2015-05-26 02:19:55 UTC
Hi!
I'm sorry, the problem wasn't the whitespace, but the "%20" we had in our solution path! After I changed the path (removing the "%20", the solution was opened without problems.

I changed the Bug-title according to this new findings.
Can you reproduce this?
Comment 3 Matt Ward 2015-06-03 08:55:08 UTC
I can repro it on the Mac but not on Windows.

My repro steps were:

1) File - New - Solution.
2) Choose a C# console app.
3) Enter foobar for the project name and foo%bar for the solution name.
4) Create the project.
5) Close the project.
6) Try to open the project again from the Recent Items list.

It fails to open it and the error message refers to the solution with a space in the path and its filename.

If you open the solution directly by using File - Open then it works.
Also if you open the solution from Finder it also works.

Looking at the recent items stored in the properties it looks like an encoding problem. In the RecentlyUsed.xml file under ~/Library/Preferences/XamarinStudio-5.0 you can see the file uri saved as:

<RecentItem>
    <URI>file://Users/username/Projects/foo%20bar/foo%20bar.sln</URI>
</RecentItem>

On Windows, which works, we have:

<RecentItem>
    <URI>file://c:\Users\username\Projects\foo%20bar\foo%20bar.sln</URI>
</RecentItem>

So it looks like the URI is saved with an incorrect value in the RecentlyUsed.xml file or it should not be interpreted as a file url but loaded as a file with the file:// part removed. Loading the string as it is currently saved into a Uri object would turn the %20 into a space character and that matches the error message we are seeing.
Comment 4 xamarin-release-manager 2015-06-11 10:03:19 UTC
Fixed in version 5.10.0.120 (master)
Comment 5 Lluis Sanchez 2015-08-25 06:43:00 UTC
*** Bug 11028 has been marked as a duplicate of this bug. ***
Comment 9 Matt Ward 2015-10-13 09:47:38 UTC
@Prashant - Sorry I meant rename it using Finder and not using Xamarin Studio.
Comment 10 Rajneesh Kumar 2015-10-13 11:56:16 UTC
Hi Matt,

I have checked this issue and below are my observations:

After creating the Console app and I rename the folder that,  path contains "%20". And the opening this project from the recent project list, I am no longer able to open it, because the path has been changed and this solution no longer exist in the recent project list.

I also observed that after changing the path I am able to open the solution via Reveal in finder=> double click on solution. After that I am successfully close and reopen the project from the recent project list.

So please let me know that should I close this issue OR I have to check something else.

Thanks..!
Comment 11 Rajneesh Kumar 2015-10-13 11:58:05 UTC
An update to comment 10.

Screencast: http://www.screencast.com/t/TfBsrG7t

Thanks..!
Comment 12 Matt Ward 2015-10-13 13:28:30 UTC
@Rajneesh - Yes please mark this as verified. The test steps you describe have verified the bug has been fixed.
Comment 13 Rajneesh Kumar 2015-10-13 13:40:11 UTC
@ Matt Thanks a lot for clarification.

As per comment 12, I am marking this issue as Verified Fixed.

Thanks..!