Bug 30189 - iOS App Extension not working
Summary: iOS App Extension not working
Status: RESOLVED ANSWERED
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime ()
Version: master
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-05-18 10:47 UTC by kechis
Modified: 2015-05-21 03:56 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
app (3.47 MB, application/zip)
2015-05-18 10:47 UTC, kechis
Details
build log (322.57 KB, application/octet-stream)
2015-05-20 09:42 UTC, kechis
Details
ios device log (81.16 KB, text/plain)
2015-05-21 03:50 UTC, kechis
Details
extension info.plist (1.50 KB, application/octet-stream)
2015-05-21 03:53 UTC, kechis
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description kechis 2015-05-18 10:47:58 UTC
Created attachment 11233 [details]
app

Hi, I've created an app with app extension but i have not found any how to make it appear in any share option from any app.

I have also tested all the samples provided in the web for app extension and none of them works.

Is this an issue with Xamarin.iOS or am i missing somthing?
Comment 1 Rolf Bjarne Kvinge [MSFT] 2015-05-19 08:31:43 UTC
You must reference the extension project from your main project.

If I do that, your app extension shows up for photos.
Comment 2 kechis 2015-05-20 03:01:02 UTC
yeah i have it referenced, I forget that in the export but no, it does not show for photos for me :/
Comment 3 Rolf Bjarne Kvinge [MSFT] 2015-05-20 04:18:03 UTC
Can you clean & rebuild your project, and attach a full build log (from the Errors pad click on the Build Output button and you'll get the build log)?
Comment 4 kechis 2015-05-20 09:42:02 UTC
Created attachment 11254 [details]
build log

there is the build log i got no issue with the build or deployment but i cant make any share functionality, from any source, to show any related thing with my extension
Comment 5 Rolf Bjarne Kvinge [MSFT] 2015-05-21 03:39:57 UTC
So it looks like the extension is included in the app.

Now can you open the iOS Device Log (in Xamarin Studio's menu View -> Pads -> iOS Device Log), connect to your device, and then run your app (so that it's uploaded to the device) and try to use it in the Photos app, then attach the output to the iOS Device Log?
Comment 6 kechis 2015-05-21 03:50:46 UTC
Created attachment 11275 [details]
ios device log
Comment 7 kechis 2015-05-21 03:53:59 UTC
Created attachment 11276 [details]
extension info.plist

uploaded both ios device log and extension info.plist since i know that could be critical, the extension is an authentication-alike one that should check user and pass since any kind of app so i would like to be available everywhere not just in photos :/

because of that i have added some parameters to the activation rule, maybe that the reason why it is not working at all, but I file this bug because no xamarin sample extension is working for me
Comment 8 Rolf Bjarne Kvinge [MSFT] 2015-05-21 03:56:14 UTC
> May 21 09:44:39 iPhone-6-Appverse installd[2406] <Error>: 0x100524000 -[MIBundle isApplicableToCurrentOSVersionWithError:]: 333: The system version is lower than the minimum OS version specified for bundle at /private/var/mobile/Library/Caches/com.apple.mobile.installd.staging/temp.X7jlUd/extracted/AppverseSample_iOS.app/PlugIns/appverse.sample.poc.AppverseExtension.appex. Have 8.1.3; need 8.3

Try setting the Deployment Target in the extension's Info.plist to 8.1

If that doesn't work, please repeat comment #5 and upload the new device log.