Bug 30173 - Compiled Form does not show TableViews.
Summary: Compiled Form does not show TableViews.
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.4.3
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-05-17 16:38 UTC by Mark Fredrickson
Modified: 2015-05-21 03:52 UTC (History)
5 users (show)

Tags: AC
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mark Fredrickson 2015-05-17 16:38:10 UTC
TableViews are not being displayed when the xaml is compiled. The following test page works fine without compilation but when compiled the TableView is not displayed. This is using Xamarin.Forms version 1.4.3.6358-pre2.

<?xml version="1.0" encoding="utf-8" ?>
<ContentPage xmlns="http://xamarin.com/schemas/2014/forms"
             xmlns:x="http://schemas.microsoft.com/winfx/2009/xaml"
             x:Class="BlueFire.Test">
  <StackLayout Orientation="Vertical" VerticalOptions="FillAndExpand">

        <Label Text="Before TableView" FontSize="20" FontAttributes="Bold"/>

        <TableView>
          <TableRoot>
            <TableSection Title="Test Title">
              <EntryCell Label="Test Label:" Placeholder="Test Entry" />
            </TableSection>
          </TableRoot>
        </TableView>

        <Label Text="After TableView" FontSize="20" FontAttributes="Bold"/>

  </StackLayout>
</ContentPage>
Comment 1 Stephane Delcroix 2015-05-21 03:52:12 UTC
Should be fixed in master. will be part of the next release including XamlC
Comment 2 Stephane Delcroix 2015-05-21 03:52:45 UTC
Should be fixed in master. will be part of the next release including XamlC