Bug 30170 - MissingManifestResourceException thrown with 'could not find any resources appropriate for the specified culture ...'
Summary: MissingManifestResourceException thrown with 'could not find any resources ap...
Status: RESOLVED DUPLICATE of bug 30044
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Xamarin.Forms Add-in ()
Version: 5.9
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Jason Smith [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2015-05-17 09:57 UTC by BillF
Modified: 2015-05-21 04:10 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Xamarin resx sample demo project, as downloaded from xamarin.com (1.10 MB, application/zip)
2015-05-17 09:57 UTC, BillF
Details
Build log ( no errors ) (124.26 KB, text/plain)
2015-05-17 10:22 UTC, BillF
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 30044

Description BillF 2015-05-17 09:57:36 UTC
Created attachment 11227 [details]
Xamarin resx sample demo project, as downloaded from xamarin.com

Component: Xamarin Studio

OS: OS-X 10.10.2

Summary: MissingManifestResourceException in arbitrary XForms app using resx resource

Description: 
On the same day that I upgraded to XS 5.9.1, MissingManifestResourceException thrown in my XForms app. Was running ok previously. App uses a resx. Same exception in a minimal XForms sample app that uses a tiny resx file. Same exception thrown in Xamarin resx sample app downloadable at http://developer.xamarin.com/guides/cross-platform/xamarin-forms/localization/ . Problem occurs after editing .resx file (causing resx code behind file to be rebuilt). Thereafter, app cannot be run without throwing the exception (unless the original code-behind file is restored). 
Note: A suspicion that the problem was also present in an earlier version, 5.9 (I skipped a few versions when upgrading). Cannot get any .resx app to run without throwing this exception, even after *completely* uninstalling XIos, XAndroid and XF, re-booting then re-installing everything. Downgraded to XS 5.8.3 + XIOS 8.9.1 + Android 4.20.2 but still got the same error.

Steps to Reproduce: 
1. Download Xamarin sample resx app from http://developer.xamarin.com/samples/UsingResxLocalization.
2. Run the app in XS -- it will run normally, displaying an application screen. Note the output from its reflection code confirming that the resx files are correctly embedded in the assembly.
3. Make a trivial edit to a <data> entry in Resx/AppResources.resx, for example change "<value>Choose a number</value>" to "<value>Choose a numberN</value>".
4. Rebuild the app and run it again.

Actual Results:
1. Message MissingManifestResourceException is thrown when the first reference is made to AppResources.resx.

Expected Results: 
The app should run as before, displaying an application screen.

Build Date & Platform: 
=== Xamarin Studio ===

Version 5.9.1 (build 3)
Installation UUID: d9517c32-6df1-40d0-934a-c35082af4e6d
Runtime:
	Mono 4.0.0 ((detached/d136b79)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400000143

=== Apple Developer Tools ===

Xcode 6.3.1 (7703)
Build 6D1002

=== Xamarin.iOS ===

Version: 8.10.0.267 (Indie Edition)
Hash: 6481535
Branch: master
Build date: 2015-04-27 04:38:13-0400

=== Xamarin.Android ===

Version: 5.1.1.0 (Indie Edition)
Android SDK: /Users/bill/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Not Installed

=== Build Information ===

Release ID: 509010003
Git revision: aad75a6e7e48f18120ce41f47d0ff2c6216f49c3
Build date: 2015-05-08 12:46:18-04
Xamarin addins: 1246b3044cbb7f56a217334f8fc5489ef8eefe3f

=== Operating System ===

Mac OS X 10.10.2
Darwin Macintosh.local 14.1.0 Darwin Kernel Version 14.1.0
    Thu Feb 26 19:26:47 PST 2015
    root:xnu-2782.10.73~1/RELEASE_X86_64 x86_64

Additional Information:
1. Comparing the project's files before the failure to those after the failure, all project files (except the edited resx file of course) appear to be unchanged -- .sln, .csproj, .info, .userprefs, AppResources.Designer.cs.

2. Placing a breakpoint on the failing line of code in the code-behind file, it can be seen that Culture was correctly set to {en}.

3. See also forum discussion at http://forums.xamarin.com/discussion/41440/missingmanifestresourceexception-could-not-find-any-resources-appropriate-for-the-specified 

4. No build errors, diagnostic error output is empty.
Comment 1 BillF 2015-05-17 10:10:14 UTC
5. In all cases tried, the resx file is in a PCL.
Comment 2 BillF 2015-05-17 10:17:39 UTC
Build action for .resx is Embedded Resource
Comment 3 BillF 2015-05-17 10:22:16 UTC
Created attachment 11228 [details]
Build log ( no errors )
Comment 4 Matt Ward 2015-05-20 09:39:24 UTC
I suspect you might be seeing bug #30044
Comment 5 BillF 2015-05-21 02:34:32 UTC
Correct, thanks Matt.
Comment 6 Matt Ward 2015-05-21 04:10:04 UTC

*** This bug has been marked as a duplicate of bug 30044 ***