Bug 30054 - Entry with IsPassword=True shows suggestions and auto-capitalizes the first letter
Summary: Entry with IsPassword=True shows suggestions and auto-capitalizes the first l...
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: 1.4.2
Hardware: All All
: Normal trivial
Target Milestone: ---
Assignee: E.Z. Hart [MSFT]
URL:
: 36196 ()
Depends on:
Blocks:
 
Reported: 2015-05-13 18:23 UTC by Jeremy Herbison
Modified: 2015-12-11 20:06 UTC (History)
5 users (show)

Tags: windows functionality ac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jeremy Herbison 2015-05-13 18:23:50 UTC
An Entry with IsPassword=True, on Windows Phone 8.1 (assuming all WinRT) configures the keyboard to auto-capitalize the first letter. Additionally, auto-complete suggestions are offered. Neither makes any sense for a password field.

The best I can find is to set the InputScope to EmailSmtpAddress when IsPassword = True. Unfortunately this adds a ".com" button, but at least solves the above two issues.

Setting Control.IsSuggestionsEnabled does not appear to help, and in fact defaults to false.
Comment 1 Jorrit 2015-11-24 04:24:33 UTC
This is a very irritating issue that has been confirmed for more than half a year ago. Please fix!
Comment 2 Quang Dang 2015-12-04 07:53:05 UTC
This issue is annoying for users. Please fix it.
Comment 4 E.Z. Hart [MSFT] 2015-12-11 20:06:24 UTC
*** Bug 36196 has been marked as a duplicate of this bug. ***