Bug 29930 - ListView (Android) does not update after selection
Summary: ListView (Android) does not update after selection
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 1.4.2
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-05-11 06:33 UTC by Peter Major
Modified: 2016-11-08 03:53 UTC (History)
5 users (show)

Tags: ac android functionality bindings RA
Is this bug a regression?: ---
Last known good build:


Attachments
Sample application (382.76 KB, application/zip)
2015-05-11 06:36 UTC, Peter Major
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Peter Major 2015-05-11 06:33:34 UTC
I'm not sure if there's a simpler test...

However, to see this defect with the sample application provided:

1. Start the application
2. Tap the 'Move' button on the first item
   This will move the item to the listview in the other tab
3. Navigate to the 'Delivered' tab.
   The item '0' should be there.
4. Tab the item.
   It should be highlighted in blue
5. Go back to the 'Delivered' tab
6. Tab the 'Move' button on the first item
7. Navigate to the 'Delivered' tab

Expected result:
The second item should be in the ListView

Actual result:
The second item is NOT in the ListView
Tap the empty space of the ListView a couple of times...
The item will appear!

It's worth noting that this bug has existed since 1.4.0 I think.

I'm stuck on 1.3.5 and haven't been able to upgrade.
Comment 1 Peter Major 2015-05-11 06:36:45 UTC
Created attachment 11148 [details]
Sample application
Comment 2 Chris King 2015-05-19 18:19:32 UTC
Behavior is as described. Could be user error however to my eye the code looks reasonable. I'd expect it to work.
Comment 3 Chris King 2015-07-15 19:19:20 UTC
On master, I can now click on Move for item one, verify a new row appeared in delivered, click on move for item two, and verify a new row appeared in delivered. This is the expected behavior so apparently another fix on master also resolved this issue. Please wait for the next release before verifying this fix.

Warm regards,
XFT
Comment 4 adrianknight89 2016-10-23 02:36:49 UTC
I don't see this issue in 2.3.3.-pre3. Can it be closed?