Bug 29915 - Installation of mono 4.0.1 fails with Segmentation fault on Raspberry Pi
Summary: Installation of mono 4.0.1 fails with Segmentation fault on Raspberry Pi
Status: RESOLVED DOWNSTREAM
Alias: None
Product: Installers
Classification: Mono
Component: General ()
Version: 4.0.0
Hardware: Other Linux
: --- normal
Target Milestone: ---
Assignee: Jo Shields
URL:
Depends on:
Blocks:
 
Reported: 2015-05-10 12:44 UTC by Patrick Gautschi
Modified: 2016-09-20 18:47 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
installation log (starting at the error) (7.89 KB, text/plain)
2015-05-10 12:46 UTC, Patrick Gautschi
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DOWNSTREAM

Description Patrick Gautschi 2015-05-10 12:44:05 UTC
When installing mono, the installation fails towards the end with a Segmentation fault (see attachment)

HW: Raspberry Pi Model B+
OS: Raspbian  2015-05-05 (default installation, no extra packages installed)

Installation procedure:
apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
echo "deb http://download.mono-project.com/repo/debian wheezy main" | tee /etc/apt/sources.list.d/mono-xamarin.list
apt-get update
apt-get install mono-complete

"mono" and "mcs" also produce a Segmentation fault after installation has completed with error.
Comment 1 Patrick Gautschi 2015-05-10 12:46:23 UTC
Created attachment 11145 [details]
installation log (starting at the error)
Comment 2 Rodrigo Kumpera 2015-05-11 14:59:59 UTC
Hi Jo,

Can you help us here?
Comment 3 Jo Shields 2015-05-11 15:30:46 UTC
mono-project.com packages are built for ARMv7, Pi model B is ARMv6. Buy a Pi 2, or rebuild the source packages
Comment 4 Patrick Gautschi 2015-05-12 01:16:16 UTC
Shouldn't the package refuse to installation when it is for a different CPU?

Are there any instructions available how to rebuild the source packages - I'm not a linux expert.

I've seen various post of people try to build 3.10 and 3.12 on RP without success.
Comment 5 Jo Shields 2015-05-12 01:56:14 UTC
It should refuse... But the Raspbian developers re used the "armhf" architecture name with different meaning, so there's no way for Apt to tell the difference