Bug 29868 - System.IO.FileNotFoundException: Could not load assembly 'MessageApp, Version=, Culture=neutral, PublicKeyToken=null'. Perhaps it doesn't exist in the Mono for Android profile?
Summary: System.IO.FileNotFoundException: Could not load assembly 'MessageApp, Version...
Status: RESOLVED DUPLICATE of bug 23210
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 5.2
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2015-05-08 04:10 UTC by Niels
Modified: 2016-04-29 21:27 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 23210

Description Niels 2015-05-08 04:10:07 UTC
Creating a new black Xamarin.Forms PCL project, I received this warning.

Warning	3	Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: System.IO.FileNotFoundException: Could not load assembly 'MessageApp, Version=, Culture=neutral, PublicKeyToken='. Perhaps it doesn't exist in the Mono for Android profile?	MessageApp.Droid

MessageApp being the solution I created.

I'm running:
Microsoft Visual Studio Community 2013
Version 12.0.31101.00 Update 4


Windows 8.1 Professional 64-bit
Comment 1 Jonathan Pryor 2015-05-08 10:22:48 UTC
Please providee diagnostic build output.

The build process is attempting to find MessageApp.dll, but cannot find it. Is it a missing assembly reference? Something else? I don't know, but diagnostic build output should help:

http://developer.xamarin.com/guides/android/troubleshooting/troubleshooting/#Diagnostic_MSBuild_Output
Comment 2 Niels 2015-05-12 02:59:26 UTC
Cleaning the solution and rebuilding it got rid of the error. I'd mark it as resolved, but having that error everytime I start a Blank PCL Xamarin application, shouldn't happen.
Comment 3 Brendan Zagaeski (Xamarin Team, assistant) 2016-04-29 21:27:24 UTC
I will mark this as a duplicate of an older bug about this same _warning_.

Note that this message can also appear as an _error_. I have filed a separate bug about improving the wording of the _error_ in Bug 40782.

*** This bug has been marked as a duplicate of bug 23210 ***