Bug 29865 - Need To Run Multiple Devices At Same Time
Summary: Need To Run Multiple Devices At Same Time
Status: RESOLVED NOT_ON_ROADMAP
Alias: None
Product: Xamarin Android Player
Classification: Xamarin
Component: Device Manager ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- enhancement
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-05-07 18:04 UTC by Ruben Macias
Modified: 2015-09-30 11:02 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_ON_ROADMAP

Description Ruben Macias 2015-05-07 18:04:22 UTC
Currently using XAP v0.3.7(1), and in previous versions, I was able to run multiple instances of different device images at the same time.  Now when I try to start another device, while another was running, I get a message box saying "Cannot Launch [DeviceName].  Please close the Xamarin Android Device that is currently running before launching [DeviceName]."

This limit kills my productivity because I was able to easily deploy to different XAP devices quickly.  For example, I would have a JellyBean, KitKat, and Lollipop device all running at the same time.  I would deploy to each using Xamarin Studio, and test out relatively quickly.  Now I have to close and launch each individual device one at a time, and this is not good for productivity.  I was able to do this in past versions, so I'm not sure why this was changed.

I would love for the ability to launch multiple device to be included back into XAP.

Thanks!
Comment 1 Mark Simpson 2015-07-20 11:52:39 UTC
Hi Ruben.
This isn't something that was removed, XAP has never supported multiple simultaneous devices.
I'm going to change this from a bug report to a feature request.
Comment 2 Will Schaller 2015-07-28 04:47:35 UTC
Closed as a feature request.
Comment 3 Will Schaller 2015-07-28 05:04:40 UTC
Error in closure.