Bug 29841 - Maps IsShowingUser displaying as red pin rather than blue dot
Summary: Maps IsShowingUser displaying as red pin rather than blue dot
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: 1.4.2
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Seth Rosetter
URL:
Depends on:
Blocks:
 
Reported: 2015-05-07 11:24 UTC by Adam Hartley [MSFT]
Modified: 2015-06-17 14:29 UTC (History)
7 users (show)

Tags: ac maps functionality
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Adam Hartley [MSFT] 2015-05-07 11:24:38 UTC
## Overview

Starting with Forms 1.4.2.6359, the user's current location is being displayed as a red pin rather than a blue dot on iOS.

## Steps to reproduce

1. Download the WorkingWithMaps example https://github.com/xamarin/xamarin-forms-samples/tree/master/WorkingWithMaps
2. Update Forms to 1.4.2.6359 or higher
3. Build and run for iOS

## Expected result

The user's current location should be displayed as a blue dot with a pulsing animation.

## Actual result

The user's current location is displayed as a red pin

## Workaround

Using a version of Forms prior to 1.4.2.6359 gives the expected result.
Comment 1 Chris King 2015-05-20 17:01:52 UTC
Seth says he fixed this.
Comment 2 Jason Smith [MSFT] 2015-05-21 05:41:27 UTC
This should be fixed in master
Comment 3 David Laundav 2015-05-21 06:46:09 UTC
I experience the exact same issue as Adam.

When will this be fixed?
Comment 4 julio 2015-06-11 08:49:55 UTC
I am running maps 1.4.2.6359 and I am still getting the red pin instead of the blue dot.

In what version was this fixed?
Comment 5 julio 2015-06-11 10:02:54 UTC
Shouldn't this bug be reopened?
Comment 6 Brendan Zagaeski (Xamarin Team, assistant) 2015-06-17 14:29:29 UTC
As per comment 0, the problem was originally reported against 1.4.2.6359, so it necessarily is not fixed in 1.4.2.6359.

The candidate fix mentioned in comment 2 will be included in the next release that is branched from "master." The engineers might be able to offer a precise version number for which version that will be.


-Brendan
Xamarin Support Team