Bug 29832 - Monkey.Robotics: FileNotFoundException: Could not load assembly 'Robotics.Mobile.Core.Droid
Summary: Monkey.Robotics: FileNotFoundException: Could not load assembly 'Robotics.Mob...
Status: RESOLVED DUPLICATE of bug 23210
Alias: None
Product: Components
Classification: Xamarin
Component: Xamarin Components ()
Version: N/A
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: CraigD
URL:
Depends on:
Blocks:
 
Reported: 2015-05-07 09:25 UTC by Steve Kledtke
Modified: 2016-04-29 21:28 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 23210

Description Steve Kledtke 2015-05-07 09:25:18 UTC
I just downloaded (github via "download zip") Monkey.Robotics and opened the .sln file of the "BLE Explorer" example in VS2013, paired to a Mac build server.

In the error list of VS2013 there is a warning saying this:

---
Warning	54	Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: System.IO.FileNotFoundException: Could not load assembly 'Robotics.Mobile.Core.Droid, Version=, Culture=neutral, PublicKeyToken='. Perhaps it doesn't exist in the Mono for Android profile?	Robotics.Mobile.BtLEExplorer.Droid
---
Comment 1 David Humphreys 2015-12-21 23:14:17 UTC
I have checked this in Visual Studio 2013 with the latest version of the VS addin and the component and it builds without any issue.

Please consider upgrading to the latest versions of Xamarin.Android for Visual Studio and the component.
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2016-04-29 21:28:15 UTC
I will mark this as a duplicate of an older bug about this same _warning_.

Note that this message can also appear as an _error_. I have filed a separate bug about improving the wording of the _error_ in Bug 40782.

*** This bug has been marked as a duplicate of bug 23210 ***