Bug 29815 - Unable to build WatchKitCatalog due to unregistered task ParseExtraMtouchArgs
Summary: Unable to build WatchKitCatalog due to unregistered task ParseExtraMtouchArgs
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild ()
Version: XI 8.10
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-05-06 16:17 UTC by Aaron Sky
Modified: 2016-06-07 08:13 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Aaron Sky 2015-05-06 16:17:58 UTC
While attempting to verify the fix in XS 5.9.1.1 for bug 29674, I have found myself unable to build WatchKitCatalog at all. The error I get is as follows and occurs after both Clean All + Build All and Rebuild All:

Error: Error initializing task ParseExtraMtouchArgs: Not registered task ParseExtraMtouchArgs. (WatchkitExtension)

I have verified that the <UsingTask TaskName="Xamarin.iOS.Tasks.ParseExtraMtouchArgs" AssemblyFile="Xamarin.iOS.Tasks.dll" /> is present in my Xamarin.iOS.Common.targets file. Attached is the build log and my environment info. It should be noted I was able to stop the problem from reproducing by restarting XS.

Build Log: https://gist.github.com/aaronsky/f628134ad7b7490d1a92

Environment Info:

=== Xamarin Studio ===

Version 5.9.1 (build 1)
Installation UUID: 0c38ad8a-9e2b-4b47-bc12-c639499efc27
Runtime:
	Mono 4.0.0 ((detached/d136b79)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400000143

=== Apple Developer Tools ===

Xcode 6.3 (7569)
Build 6D570

=== Xamarin.Android ===

Version: 5.1.0.115 (Business Edition)
Android SDK: /Volumes/Needle/Users/aaronsky/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.7.0_79"
Java(TM) SE Runtime Environment (build 1.7.0_79-b15)
Java HotSpot(TM) 64-Bit Server VM (build 24.79-b02, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Xamarin.iOS ===

Version: 8.10.1.24 (Business Edition)
Hash: 1b48440
Branch: master
Build date: 2015-05-04 17:01:32-0400

=== Xamarin.Mac ===

Version: 2.0.1.28 (Business Edition)

=== Build Information ===

Release ID: 509010001
Git revision: ab10ce5827c2f88e8dc00e8860d7a96cf5063ac9
Build date: 2015-05-06 10:56:51-04
Xamarin addins: 710e3c38554f33739500150094e1f31c046486ca

=== Operating System ===

Mac OS X 10.10.3
Darwin Aarons-iMac.local 14.3.0 Darwin Kernel Version 14.3.0
    Mon Mar 23 11:59:05 PDT 2015
    root:xnu-2782.20.48~5/RELEASE_X86_64 x86_64
Comment 1 Rolf Bjarne Kvinge [MSFT] 2015-05-07 07:00:29 UTC
Did you upgrade Xamarin.iOS without restarting Xamarin Studio? That would cause this problem.
Comment 2 Rolf Bjarne Kvinge [MSFT] 2016-06-07 08:13:54 UTC
We have not received the requested information. If you are still 
experiencing this issue please provide all the requested information 
and re-open the bug report. Thanks!