Bug 29785 - Nokia-X Maps Google compete plugin fails to work on emulator or real device
Summary: Nokia-X Maps Google compete plugin fails to work on emulator or real device
Status: RESOLVED FIXED
Alias: None
Product: Components
Classification: Xamarin
Component: Xamarin Components ()
Version: Production (addons.xamarin.com)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bill Holmes
URL:
Depends on:
Blocks:
 
Reported: 2015-05-06 05:56 UTC by Paul Johnson
Modified: 2015-05-06 09:05 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Paul Johnson 2015-05-06 05:56:10 UTC
I have installed the Nokia-X Here component from the component store, opened the examples and built to the Nokia-X emulator. When run on the emulator (or on a Samsung S3), I get the same result

Java.Lang.NoClassDefFoundError: com.google.android.gms.maps.SupportMapFragment$1
at at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () 
at Android.Runtime.JNIEnv.CallNonvirtualVoidMethod (intptr,intptr,intptr,Android.Runtime.JValue*) [0x00084] in /Users/builder/data/lanes/1502/bc809d52/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.g.cs:1029
at Android.App.Activity.SetContentView (int) [0x00070] in /Users/builder/data/lanes/1502/bc809d52/source/monodroid/src/Mono.Android/platforms/android-16/src/generated/Android.App.Activity.cs:4709
at Samples.Here.GoogleMapsApi.BasicMapDemoActivity.OnCreate (Android.OS.Bundle) [0x0000e] in /Users/Paul/Developer/nokia/Components/NokiaHEREGoogleMapsV2-3.0.0/samples/GoogleMapsV2Demo/GoogleMapsV2Demo/Resources/BasicMapDemoActivity.cs:26
at Android.App.Activity.n_OnCreate_Landroid_os_Bundle_ (intptr,intptr,intptr) [0x00011] in /Users/builder/data/lanes/1502/bc809d52/source/monodroid/src/Mono.Android/platforms/android-16/src/generated/Android.App.Activity.cs:2374
at at (wrapper dynamic-method) object.0a9ec456-a72c-42c3-b796-ffdba7a79ee9 (intptr,intptr,intptr) 
at --- End of managed exception stack trace ---
at java.lang.NoClassDefFoundError: com.google.android.gms.maps.SupportMapFragment$1
at at com.google.android.gms.maps.SupportMapFragment.onAttach(SupportMapFragment.java:122)
at at android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:907)
at at android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:1116)
at at android.support.v4.app.FragmentManagerImpl.addFragment(FragmentManager.java:1218)
at at android.support.v4.app.FragmentManagerImpl.onCreateView(FragmentManager.java:2170)
at at android.support.v4.app.FragmentActivity.onCreateView(FragmentActivity.java:300)
at at android.view.LayoutInflater.createViewFromTag(LayoutInflater.java:691)
at at android.view.LayoutInflater.inflate(LayoutInflater.java:470)
at at android.view.LayoutInflater.inflate(LayoutInflater.java:398)
at at android.view.LayoutInflater.inflate(LayoutInflater.java:354)
at at com.android.internal.policy.impl.PhoneWindow.setContentView(PhoneWindow.java:361)
at at android.app.Activity.setContentView(Activity.java:1956)
at at md5f5ea1e8e9416990e7f116b74586b2277.BasicMapDemoActivity.n_onCreate(Native Method)
at at md5f5ea1e8e9416990e7f116b74586b2277.BasicMapDemoActivity.onCreate(BasicMapDemoActivity.java:29)
at at android.app.Activity.performCreate(Activity.java:5372)
at at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1104)
at at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2257)
at at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2349)
at at android.app.ActivityThread.access$700(ActivityThread.java:159)
at at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1316)
at at android.os.Handler.dispatchMessage(Handler.java:99)
at at android.os.Looper.loop(Looper.java:176)
at at android.app.ActivityThread.main(ActivityThread.java:5419)
at at java.lang.reflect.Method.invokeNative(Native Method)
at at java.lang.reflect.Method.invoke(Method.java:525)
at at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:1046)
at at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:862)
at at dalvik.system.NativeStart.main(Native Method)

My phone has Google Play Services installed by default (it's an S3 after all). If I try and install play services as a library into the project, I get build errors. Removal allows for the demo to build but not run.

Is this just a case of relinking to a newer google play service module or does it require something more?  If the component was on github, I would have a go at doing the rebuild or try to sort the issue.

I'm using the v3.0.0 release from the store with valid credentials from the Opera Store (formerly Nokia store)

=== Xamarin Studio ===

Version 5.9 (build 464)
Installation UUID: 728e2a5d-c6a2-4d84-a931-ee64cb78694c
Runtime:
	Mono 4.0.1 ((detached/5a0b19f)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400010024

=== Apple Developer Tools ===

Xcode 6.3.1 (7703)
Build 6D1002

=== Xamarin.Android ===

Version: 5.1.0.129 (Business Edition)
Android SDK: /Users/Paul/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.8.0_20-ea"
Java(TM) SE Runtime Environment (build 1.8.0_20-ea-b21)
Java HotSpot(TM) 64-Bit Server VM (build 25.20-b20, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Xamarin.iOS ===

Version: 8.10.1.24 (Business Edition)
Hash: 1b48440
Branch: master
Build date: 2015-05-04 17:01:32-0400

=== Xamarin.Mac ===

Version: 2.0.1.24 (Business Edition)

=== Build Information ===

Release ID: 509000464
Git revision: 97f3c43266a4abe2dff0a31b1afb976de897d099
Build date: 2015-05-04 10:06:54-04
Xamarin addins: 438f3e4b8352e006958552de07c6f54770c9233c

=== Operating System ===

Mac OS X 10.10.4
Darwin Pauls-MacBook-Pro.local 14.4.0 Darwin Kernel Version 14.4.0
    Sun Apr 19 20:30:19 PDT 2015
    root:xnu-2782.30.2~2/RELEASE_X86_64 x86_64
Comment 1 Jon Dick 2015-05-06 09:05:04 UTC
This component was created to be used exclusively on the "Nokia X" platform http://www.microsoft.com/en/mobile/phones/nokia-x/ which has since been deprecated by Microsoft.  It will not work on normal android devices and the component will be de-listed soon.  

Please try Google Maps via Google Play Services instead.

Thanks