Bug 29729 - The Time Profiler only show 0ms in an empty Xamarin.Android sample app
Summary: The Time Profiler only show 0ms in an empty Xamarin.Android sample app
Status: RESOLVED ANSWERED
Alias: None
Product: Profiler
Classification: Xamarin
Component: General ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Rodrigo Moya
URL:
Depends on:
Blocks:
 
Reported: 2015-05-04 22:03 UTC by Jerome Laban
Modified: 2015-07-08 05:57 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
VS2015 RC version (2.88 KB, text/plain)
2015-05-04 22:03 UTC, Jerome Laban
Details
profiler screenshot (90.18 KB, image/png)
2015-05-04 22:03 UTC, Jerome Laban
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Jerome Laban 2015-05-04 22:03:24 UTC
Created attachment 11063 [details]
VS2015 RC version

Using the profiler 0.13.0.0, when profiling an "Empty sample application" from VS2015 RC, the profiler only shows 0.00ms in the time profiler, even though it took more to actually run.

See the attached screenshot, and VS version,
Comment 1 Jerome Laban 2015-05-04 22:03:48 UTC
Created attachment 11064 [details]
profiler screenshot
Comment 2 Rodrigo Moya 2015-05-06 07:42:20 UTC
Yes, we retrieve timing information from sampling, which currently doesn't work on Android. But a fix is coming pretty soon, so should be available in the alpha/beta channels in the next few weeks.

We are tracking that in another bug, so closing this one. Please pay attention to the profiler's release notes, which will include information on when that's fixed. So, when that happens, feel free to re-open this if it doesn't work.
Comment 3 Joseph Redfern 2015-07-08 05:57:32 UTC
Are there any updates on this, or a link to the other ticket you speak of that is tracking this issue?