Bug 29674 - german Umlauts (special characters) are wrong in labels
Summary: german Umlauts (special characters) are wrong in labels
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-05-02 08:44 UTC by kalisami
Modified: 2017-01-23 22:40 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Umlauts like "ß","ä","ü","ö" etc are now "??" (70.87 KB, image/png)
2015-05-02 08:44 UTC, kalisami
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description kalisami 2015-05-02 08:44:25 UTC
Created attachment 11030 [details]
Umlauts like "ß","ä","ü","ö" etc are now "??"

Since the last update, german special characters are just two question marks when debugging on my iPhone.

However, when I debug the exact same App on the Simulator, this bug does not appear. 

The following person seems to have a similar problem: 
http://forums.xamarin.com/discussion/39700/umlauts-issue-since-1-4-2-6359

I am using VS 2013, my build host is a MacBook Pro Retina 15 Late 2013.
Comment 1 kalisami 2015-05-02 11:55:55 UTC
I downgraded Xamarin.iOS on both my Build Host and Windows, it works now. Still, this needs to be fixed!
Comment 2 Tajinder Singh 2015-05-07 03:31:46 UTC
I have tried and unable to reproduce this issue by bug description, i.e with using characters "ß","ä","ü","ö" etc are now "??"

Steps followed:
1. Open VS 2013
2. Create Forms application(Portable).
3. Change "ßäüö" in text.
4. Deploy app on iphone4S ios 8.2

Could you please provide us the test steps you followed. If possible please
attach a small complete project that demonstrates this behavior.

Can you please add the logs/info from the following places?:
IDE log: Location: C:\User\AppData\Local\Xamarin\Log\ 
(Devenev file with latest timestamp)
Android Trace log: Location: \AppData\Local\Xamarin\Log\XamarinAndroid

Also please specify the language versions (English or other language) you are using for VS and Windows OS.

Environment Info:
Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.6.00057

Installed Version: Professional

LightSwitch for Visual Studio 2013   06177-004-0446016-02251
Microsoft LightSwitch for Visual Studio 2013

Team Explorer for Visual Studio 2013   06177-004-0446016-02251
Microsoft Team Explorer for Visual Studio 2013

Visual Basic 2013   06177-004-0446016-02251
Microsoft Visual Basic 2013

Visual C# 2013   06177-004-0446016-02251
Microsoft Visual C# 2013

Visual C++ 2013   06177-004-0446016-02251
Microsoft Visual C++ 2013

Visual F# 2013   06177-004-0446016-02251
Microsoft Visual F# 2013

Visual Studio 2013 Code Analysis Spell Checker   06177-004-0446016-02251
Microsoft® Visual Studio® 2013 Code Analysis Spell Checker

Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V. All rights reserved.

The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company. Electronic version licensed from Lernout & Hauspie Speech Products N.V. All rights reserved.

Application Insights Tools for Visual Studio Package   1.0
Application Insights Tools for Visual Studio

ASP.NET and Web Tools   12.4.51016.0
Microsoft Web Developer Tools contains the following components:
Support for creating and opening ASP.NET web projects
Browser Link: A communication channel between Visual Studio and browsers
Editor extensions for HTML, CSS, and JavaScript
Page Inspector: Inspection tool for ASP.NET web projects
Scaffolding: A framework for building and running code generators
Server Explorer extensions for Microsoft Azure Websites
Web publishing: Extensions for publishing ASP.NET web projects to hosting providers, on-premises servers, or Microsoft Azure

ASP.NET Web Frameworks and Tools 2012.2   4.1.21001.0
For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

ASP.NET Web Frameworks and Tools 2013   5.2.21010.0
For additional information, visit http://www.asp.net/

Common Azure Tools   1.3
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

Microsoft Azure Mobile Services Tools   1.3
Microsoft Azure Mobile Services Tools

NuGet Package Manager   2.8.50926.663
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

Office Developer Tools for Visual Studio 2013 ENU   12.0.30626
Microsoft Office Developer Tools for Visual Studio 2013 ENU

PowerShell Tools   1.3
Provides file classification services using PowerShell

PreEmptive Analytics Visualizer   1.2
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

SQL Server Data Tools   12.0.41012.0
Microsoft SQL Server Data Tools

Windows Phone 8.1 SDK Integration   1.0
This package integrates the tools for the Windows Phone 8.1 SDK into the menus and controls of Visual Studio.

Workflow Manager Tools 1.0   1.0
This package contains the necessary Visual Studio integration components for Workflow Manager.

Xamarin   3.11.507.0 (dfac85e)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   5.1.0.127 (cbdf025e886eacb95ce7adf53346961156fae990)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.Forms Intellisense   1.0
Provides intellisense for Xamarin.Forms in the XML editor.

Xamarin.iOS   8.10.0.0 (7741cc495ab0baf04ff0405d0604bc27f0ecae2e)
Visual Studio extension to enable development for Xamarin.iOS.

Xamarin.iOS Unified Migration   1.0
Automated migration for Xamarin iOS Classic projects to Unified

Xamarin.TestCloud.Integration   1.0
Early preview of Xamarin Test Cloud integration
Comment 3 Vincent Dondain [MSFT] 2017-01-23 22:40:09 UTC
Just tried with a quick test case and it works: https://www.dropbox.com/s/d3d5gzf419rhlnr/Bug29674.zip?dl=0

Not sure it's similar to what's being reported here since we do not have the original test case :P

I'm closing this bug as I cannot reproduce it. If you are still experiencing this issue please provide us a test case and re-open the bug report. Thanks!