Bug 29673 - Could not find SDK platform directory
Summary: Could not find SDK platform directory
Status: RESOLVED ANSWERED
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler ()
Version: 4.1.x
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2015-05-02 06:34 UTC by kishan.dubal
Modified: 2015-05-05 17:37 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description kishan.dubal 2015-05-02 06:34:36 UTC

    
Comment 1 kishan.dubal 2015-05-02 06:38:01 UTC
C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(3,3): Error XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: Could not find SDK platform directory 'C:\Users\Kishan\AppData\Local\Android\android-sdk\platforms\android-16'.  Are --sdk-dir and --sdk-version set appropriately? (XA0000) (XamarinStore.Droid)
Comment 2 Sunil Kumar 2015-05-04 07:32:36 UTC
I have tried to reproduce this issue but unable to reproduce it. I am successfully able to build and deploy android application with SDK Target Framework 16 on device and Emulators. Here is the screencast: http://www.screencast.com/t/Rlm4qmCRNqf8

@Kishan, Could you please make sure that android-16 is installed in android-sdk\platforms and also Android SDK is updated on you machine

Also if possible could you please provide us ide logs, build info and sample so that we can reproduce this issue at our end.

For ide log,Location: XS-> Help-> Open log Directory-> ide.log(latest time stamp)
For Build info, Location XS-> Help-?> About-> Show details-> Copy information.

Environment info: 
Device: Moto X 5.0 and API 21 Emulator.

=== Xamarin Studio ===

Version 5.9 (build 431)
Installation UUID: af8b0e23-bef7-4d92-b9de-c688528f8f70
Runtime:
 Microsoft .NET 4.0.30319.34011
 GTK+ 2.24.22 (MS-Windows theme)
 GTK# 2.12.26

=== Xamarin.Android ===

Version: 5.1.0 (Enterprise Edition)
Android SDK: C:\Users\Naqeeb\AppData\Local\Android\android-sdk
 Supported Android versions:
  2.3    (API level 10)
  4.0.3  (API level 15)
  4.1    (API level 16)
  4.2    (API level 17)
  4.3    (API level 18)
  4.4    (API level 19)
  4.4.87 (API level 20)
  5.0    (API level 21)
Java SDK: C:\Program Files\Java\jdk1.7.0_71
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Version: 0.1.1
Location: C:\Program Files\Xamarin Android Player\DeviceManager.exe

=== Build Information ===

Release ID: 509000431
Git revision: 7560726734fc7267de2fa9abed2509968deefaa8
Build date: 2015-04-17 17:09:09-04
Xamarin addins: 2e772c734ab3148054eae7bf8949f340fdeb5e5e

=== Operating System ===

Windows 6.2.9200.0 (64-bit)
Comment 3 Jonathan Pryor 2015-05-05 17:37:43 UTC
@kishan.dubal: "Something" wants to use API-16 -- e.g. $(TargetFrameworkVersion) is v4.1, or your Properties\AndroidManifest.xml has a //uses-sdk/@android:targetSdkVersion attribute value of "16".

Unfortunately, you don't have API-16 installed, so you can't use it.

Either change your project so that you're not attempting to reference API-16, and instead reference something you DO have installed, or install API-16:

http://developer.xamarin.com/recipes/cross-platform/ide/launch_sdk_manager/

You can use the SDK Manager to install additional API levels.