Bug 29634 - When losing connection to the build server, the error panel keeps popping up
Summary: When losing connection to the build server, the error panel keeps popping up
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 3.11 (C5)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-05-01 04:11 UTC by Jim Bennett
Modified: 2015-05-04 16:08 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jim Bennett 2015-05-01 04:11:20 UTC
Setup:

MacBookPro running Xamarin build host (10.10.3, latest Xamarin as of 28th April 2015)
Surface Pro 2 running VS2013 community (Windows 8.1, latest Xamarin as of 28th April 2015)

Create a new Xamarin Forms project.
Start coding.

After a while the MBP goes to sleep, and the connection to the iOS build host is lost.  The VS error panel pops up with a warning about a lost connection and an error about another instance of VS using the build host.
This pops up every second - closing the panel or hiding it doesn't work, it still pops up.  Not only is it distracting but the focus is stolen from the editor so you can't even carry on typing.

The only workaround is to wake the Mac up, double click on the error to reconnect, choose the same build host as before and let it connect - it doesn't even reconnect automatically.

Removing the iOS project from the solution makes no difference, it still wants to connect.

It should only error on building, not whilst purely coding.  It also shouldn't error if the iOS projects in the solution are removed.
Comment 1 Daniel Cazzulino 2015-05-04 16:06:15 UTC
Hi Jim, 
could you copy/paste the Help | About Microsoft Visual Studio version information?

I can't repro this with our latest stable. Timing might have been against you in this particular case. The new stable bits shipped the day after you reported the issue :(.

The new stable build is 3.11.445.
Comment 2 Daniel Cazzulino 2015-05-04 16:08:10 UTC
Verified as fixed in 3.11.445. It's now a warning and we no longer force-show the error list.