Bug 29624 - Appearance issues with iOS 8.10 STABLE
Summary: Appearance issues with iOS 8.10 STABLE
Status: RESOLVED ANSWERED
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime ()
Version: XI 8.10
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-04-30 17:17 UTC by Neal
Modified: 2015-05-01 16:57 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
rows should be black with white text - heavily customized appearance theme (242.96 KB, image/png)
2015-04-30 17:17 UTC, Neal
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Neal 2015-04-30 17:17:11 UTC
Created attachment 10997 [details]
rows should be black with white text - heavily customized appearance theme

Hello,

After updating to the latest stables we are experience significant appearance proxy issues (unified) on iPad Air SIM 8.3 in tests.  The same code tested against Xam Studio 5.8.3 with iOS 8.9.1.3 works perfectly.  I'm not sure what else to provide but I'll attach a screenshot which is one of about a half dozen that we have problems with.

Thank you.

=== Xamarin Studio ===

Version 5.9 (build 431)
Installation UUID: 25d1d6a6-72c5-479c-b704-f939b8920555
Runtime:
	Mono 4.0.0 ((detached/d136b79)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400000143

=== Xamarin.Android ===

Version: 5.1.0.115 (Business Edition)
Android SDK: /Users/Neal/Applications/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.4   (API level 19)
Java SDK: /usr
java version "1.8.0_40"
Java(TM) SE Runtime Environment (build 1.8.0_40-b25)
Java HotSpot(TM) 64-Bit Server VM (build 25.40-b25, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 6.3.1 (7703)
Build 6D1002

=== Xamarin.iOS ===

Version: 8.10.0.267 (Business Edition)
Hash: 6481535
Branch: master
Build date: 2015-04-27 04:38:13-0400

=== Xamarin.Mac ===

Version: 2.0.0.262 (Business Edition)

=== Build Information ===

Release ID: 509000431
Git revision: 7560726734fc7267de2fa9abed2509968deefaa8
Build date: 2015-04-17 19:25:48-04
Xamarin addins: 2e772c734ab3148054eae7bf8949f340fdeb5e5e

=== Operating System ===

Mac OS X 10.10.3
Darwin iMACRH.local 14.3.0 Darwin Kernel Version 14.3.0
    Mon Mar 23 11:59:05 PDT 2015
    root:xnu-2782.20.48~5/RELEASE_X86_64 x86_64
Comment 1 Rolf Bjarne Kvinge [MSFT] 2015-05-01 03:25:26 UTC
Can you zip up and attach your project so that we can reproduce this ourselves?
Comment 2 Neal 2015-05-01 08:48:29 UTC
Rolf,

No, I don't think I'm going to be able to provide this massive solution but it's more of a heads up to you that I'm seeing appearance issues.  I'm going to dig into this today to see if there is anything I can tweak on my end that maybe the updates exposed as fragile.  I'll report back should I have anything to add.
Comment 3 Rolf Bjarne Kvinge [MSFT] 2015-05-01 08:55:15 UTC
There were a few bug fixes to the GetAppearance* methods, which technically could cause changes (for instance GetAppearance calls that had no effect previously now starts working).
Comment 4 Neal 2015-05-01 08:58:31 UTC
That's what I'm thinking, the half dozen views that have this issue (not all) just need some investigation and correction.  I'll report back and close the case if all is good or provide more info.

Thank you again.
Comment 5 Neal 2015-05-01 16:57:18 UTC
Had to set a bunch of views to BackgroundColor.Clear but it's all "cleared up" now :)

Thanks