Bug 2959 - Unavailable Toolstrips receiving keypresses.
Summary: Unavailable Toolstrips receiving keypresses.
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: Windows.Forms ()
Version: 2.10.x
Hardware: PC Windows
: Lowest normal
Target Milestone: Community
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-01-18 16:43 UTC by Tom Hindle
Modified: 2017-09-01 11:56 UTC (History)
1 user (show)

Tags: mono-community
Is this bug a regression?: ---
Last known good build:


Attachments
Test case showing issue (1.93 KB, text/plain)
2012-01-18 16:43 UTC, Tom Hindle
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 2959 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Tom Hindle 2012-01-18 16:43:07 UTC
Created attachment 1226 [details]
Test case showing issue

Attached test case demonstrating issue.

To reproduce run test case and press Control-E.

.NET results:

Pressing Control-E does NOT show "Item1 Clicked" message box.

outputs to console:

Before move
item = menu1
Owner = System.Windows.Forms.MenuStrip, Name: real, Items: 1
Owner.TopLevelControl = System.Windows.Forms.Form, Text:
After move
item = menu1
Owner = System.Windows.Forms.MenuStrip, Name: dummy, Items: 1
Owner.TopLevelControl =
MainMenuStrip items count = 0

mono results:

Pressing Control-E shows message box "Item1 Clicked"

output to console:


Before move
item = menu1
Owner = System.Windows.Forms.MenuStrip, Name: real, Items: 1
Owner.TopLevelControl = System.Windows.Forms.Form, Text:
After move
item = menu1
Owner = System.Windows.Forms.MenuStrip, Name: real, Items: 0
Owner.TopLevelControl = System.Windows.Forms.Form, Text:
MainMenuStrip items count = 0
Comment 1 Tom Hindle 2012-01-18 16:47:35 UTC
So it seems that on mono when submenu1 is moved to the dummymenu by ToolStripManager.Merge its Owner property isn't updated. Despite dummymenu.Items containing submenu1.