Bug 2954 - The Deploy to device popup is modal. Blocks Visual Studio.
Summary: The Deploy to device popup is modal. Blocks Visual Studio.
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-01-18 11:06 UTC by somyaj
Modified: 2016-08-03 15:22 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description somyaj 2012-01-18 11:06:35 UTC
This is annoying as it blocks me form editing in Visual Studio for almost a minute as the app is deploying. Please make the popup non modal.
Comment 1 Peter Collins 2013-05-21 14:52:27 UTC
We no longer display a modal dialog window while the app is being packaged and installs. This window disappears once the user selects an available device / emulator image, allowing editing during the deployment process.
Comment 2 Peter Collins 2013-05-21 14:53:08 UTC
Fix verified in XA (4.6.6 - 6d7480e9)