Bug 29412 - [iOS] RootViewController doesn't show the controls on the Page
Summary: [iOS] RootViewController doesn't show the controls on the Page
Status: RESOLVED NORESPONSE
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.4.1
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jason Smith [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2015-04-27 01:54 UTC by Anubhav Ranjan
Modified: 2016-04-13 18:05 UTC (History)
6 users (show)

Tags: ios functional
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Anubhav Ranjan 2015-04-27 01:54:29 UTC
One of the customers is facing issue with RootViewController not showing the Forms Control

#Description:
===========
the issue is the screen that loaded as a blank white screen, 
the controls (Button and Entry that is on first screen) are not loaded. 
Whole screen is as a Blank White Screen.
I can't understand , What is happing here now? Why a blank screen 
comes ? How can I set my Xaml Page as RootViewController ?

I have given Gray background to the StartupPage, the screen must show 
grey there but it will appears just white. While I give background color 
to RootViewController, its color changed.

#Sample:
======
https://dl.dropboxusercontent.com/u/30949500/Xamarin%20Samples/ShoppingCartXF-master.zip
Comment 1 Seth Rosetter 2015-05-15 14:10:30 UTC
I have downloaded the sample and saw you are running Forms 1.2.2. if you update to use latest stable https://www.nuget.org/packages/Xamarin.Forms/ and migrate your App initialization logic to use our Application class (introduced in 1.3.0), do you still encounter this issue? Below is a link to guide you when updating to use the application class. 

http://developer.xamarin.com/guides/cross-platform/macios/updating-xamarin-forms-apps/
Comment 2 Samantha Houts [MSFT] 2016-04-13 18:05:27 UTC
Thank you for your bug report. As we have not received the information requested, we cannot properly triage your bug and are marking it resolved.

Warm regards,
Xamarin Forms Team