Bug 29352 - Expected Xamarin.Forms 1.4.2.6355 Update Problem
Summary: Expected Xamarin.Forms 1.4.2.6355 Update Problem
Status: RESOLVED UPSTREAM
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Xamarin.Forms Add-in ()
Version: unspecified
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: Jason Smith [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2015-04-23 14:34 UTC by Clay Martin
Modified: 2015-09-09 04:38 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED UPSTREAM

Description Clay Martin 2015-04-23 14:34:14 UTC
Description of Problem:
I did the xamarin.forms update (1.4.2.6355) in my IOS project in Xamarin Studio today. Since then (I assume it’s related), I’ve been getting the following error when I navigate to specific pages in my app in the simulator:

Steps to reproduce the problem:
1. Build IOS Project and run
2. Navigate to specific pages in my app


Actual Results:
System.TypeLoadException.
Could not load type Xamarin.Forms.Platform._LabelRenderer, Xamarin.Forms.Platform, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null while decoding custom attribute


Expected Results:
Load the page

How often does this happen? 
Every time I navigate to specific pages in my app in the simulator


Additional Information:
Comment 1 Clay Martin 2015-04-23 15:55:01 UTC
It turns out the error I'm experiencing is caused by xamarin.forms xaml syntax in the Xamarin.Forms 1.4.2.6355 update. 

The following causes the error (text value nested in between the opening and closing tags):
<Label  x:Name="WeightMaxLabel" VerticalOptions="Center" HorizontalOptions="End" TextColor="Gray" WidthRequest="35”>30</Label>  

The following will not cause an error (text value in the Text attribute):
<Label  x:Name="WeightMaxLabel" VerticalOptions="Center" HorizontalOptions="End" TextColor="Gray" WidthRequest=“35” Text=“30"></Label>  

Prior to this last update, the syntax in the first example would not cause an error.
Comment 2 Sunil Kumar 2015-04-24 07:25:40 UTC
I have tried to reproduce this issue and able to reproduce. I have followed below steps to reproduce this issue:

1. Create Xamarin.Forms PCL project.
2. Add .xaml file
3. Add the below code to xaml file:
<Label  x:Name="WeightMaxLabel" VerticalOptions="Center"
HorizontalOptions="End" TextColor="Gray" WidthRequest="35”>30</Label> 
4. Make the iOS project as startup project.
5. Update the Xamarin.Forms package to 4.1.2.6355.
6. Run the application.

Observed that we are also getting the same exception during navigation to specific page.

NOTE: Using below code mentioned in comment 2, it's working fine and not throws any exception

<Label  x:Name="WeightMaxLabel" VerticalOptions="Center"
HorizontalOptions="End" TextColor="Gray" WidthRequest=“35” Text=“30"></Label> 

Screencast: http://www.screencast.com/t/2b8E6rPBe04
IDE Logs: https://gist.github.com/sunil360/138399136fb42b7ea44d
Exception: https://gist.github.com/sunil360/a5bdead65584d0712810
Application Output: https://gist.github.com/sunil360/dbff551528da74465c97

Environment Info:
Xamarin.Forms 4.1.2.6355

=== Xamarin Studio ===

Version 5.9 (build 431)
Installation UUID: 561c7a69-0a91-4bae-ad7c-f0c79d594337
Runtime:
	Mono 4.0.0 ((detached/d136b79)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400000143

=== Apple Developer Tools ===

Xcode 6.3 (7569)
Build 6D570

=== Xamarin.iOS ===

Version: 8.10.0.266 (Trial Edition)
Hash: c8648f0
Branch: master
Build date: 2015-04-21 12:22:24-0400

=== Xamarin.Android ===

Version: 5.1.0.115 (Trial Edition)
Android SDK: /Users/tajinder/Desktop/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_67"
Java(TM) SE Runtime Environment (build 1.7.0_67-b01)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.0.0.262 (Trial Edition)

=== Build Information ===

Release ID: 509000431
Git revision: 7560726734fc7267de2fa9abed2509968deefaa8
Build date: 2015-04-17 19:25:48-04
Xamarin addins: 2e772c734ab3148054eae7bf8949f340fdeb5e5e

=== Operating System ===

Mac OS X 10.10.0
Darwin Tajinders-iMac.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 3 David Karlaš 2015-09-09 04:38:33 UTC
This is fixed by updating to newer version of Xamarin.Forms.