Bug 29175 - Post(action)/PostDelayed(action) and RemoveCallbacks(action) don't behave as expected
Summary: Post(action)/PostDelayed(action) and RemoveCallbacks(action) don't behave as ...
Status: RESOLVED NORESPONSE
Alias: None
Product: Android
Classification: Xamarin
Component: BCL Class Libraries ()
Version: 5.2
Hardware: All All
: High normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2015-04-17 03:34 UTC by Cortez9
Modified: 2017-09-14 19:20 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample Project (28.81 KB, application/octet-stream)
2015-07-08 14:34 UTC, Abhishek
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Cortez9 2015-04-17 03:34:51 UTC
http://forums.xamarin.com/discussion/38199/post-action-postdelayed-action-and-removecallbacks-action-dont-behave-as-expected


Note:
Re-posting a "Runnable" within itself is very common. This is not a rare use-case. The C# equivalent (posting an action instead of a Runnable) should work just as fine. I suggested a fix at the end of the thread.
Comment 1 Abhishek 2015-07-08 14:34:27 UTC
Created attachment 11939 [details]
Sample Project

I have tried this issue but unable to reproduce the reported behavior at my end.

I am attaching my sample project please have a look.If its possible could you please attach the sample project along with the bug so that I can reproduce this issue at my end. It would be great if you provide the IDE log, Application output, Adb logcat, Environment Info.

For VS:

Environment Info via Help->About Microsoft visual studio. 
IDE log via Help->Xamarin->Zip Xamarin Logs.

For XS:

Environment Info via Help->About->Show Details.
IDE Log via Help->Open Log Directory.

Environment Info:

=== Xamarin Studio ===

Version 5.9.4 (build 5)
Installation UUID: 9964a087-9af9-4da0-aa20-07ca4b85f306
Runtime:
	Microsoft .NET 4.0.30319.0
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.26

=== Xamarin.Android ===

Version: 5.1.4 (Business Edition)
Android SDK: D:\android-sdk
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: C:\Program Files (x86)\Java\jdk1.7.0_71
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) Client VM (build 24.71-b01, mixed mode, sharing)

=== Xamarin Android Player ===

Version: 0.3.7.2
Location: C:\Program Files\Xamarin Android Player\DeviceManager.exe

=== Build Information ===

Release ID: 509040005
Git revision: 8010a90f6e246b32364e3fb46ef2c9d1be9c9a2b
Build date: 2015-06-08 17:16:25-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

=== Operating System ===

Windows 6.1.7601.65536 (64-bit)
Comment 2 Jon Douglas [MSFT] 2017-09-14 19:20:25 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!