Bug 29150 - Urgent: Playing a video with Xamarin for iOS broken after latest update
Summary: Urgent: Playing a video with Xamarin for iOS broken after latest update
Status: RESOLVED INVALID
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.1
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-04-16 07:31 UTC by supreet
Modified: 2015-05-26 14:43 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description supreet 2015-04-16 07:31:02 UTC
The following code in Xamarin for iOS was working fine prior to the Xamarin for iOS update to v2.0.50727

As i said this was working till day before yesterday, after which I installed 2 updates on Xamarin. iOS & this is now failing. All i see is a black canvas & the video never loads. No notifications from the MPMoviePlayerController are ever raised. There is a release of this app scheduled for next week & this last minute bug is causing me headaches. Any help is really appreciated.

You can find the sample code here 
https://github.com/supreettare/moviePlayerDemo

Version Info: 

VS Stable Channel : Up to Date 
MAC Stable Channel : Up to Date 
iPad used for testing version 8.3 (12F69) 

Xamarin.Forms runtime version v4.0.30319, version 1.3.1.0
Xamarin.IOs runtime version v2.0.50727

I need to release this app soon. It will be a real help if someone can patch this. 

Thanks 
ST
Comment 1 Rui Marinho 2015-05-26 14:43:06 UTC
Hi i have checked the issue, and i think the problem is in your mp4 url.

I changed to this one http://techslides.com/demos/sample-videos/small.mp4 , and it works ok. 

Thanks