Bug 29147 - Size Classes with deployment target < iOS 8
Summary: Size Classes with deployment target < iOS 8
Status: RESOLVED DUPLICATE of bug 29100
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild ()
Version: XI 8.10
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on: 29100
Blocks:
  Show dependency tree
 
Reported: 2015-04-16 06:11 UTC by blitzillu
Modified: 2015-04-27 04:36 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 29100

Description blitzillu 2015-04-16 06:11:57 UTC
Create a unified API project. Set deployment target to iOS 7. Place an UIView on MainStoryboard and add some constraints. Select iOS Device with iOS 7.1 and try to run the project. You get

Objective-C exception thrown.  Name: NSInvalidArgumentException Reason: Could not find a storyboard named 'MainStoryboard' in bundle NSBundle </Users/someuser/Library/Developer/CoreSimulator/Devices/AEF80A2D-FFC5-4015-A0B0-C93BAEE58C86/data/Applications/A78CAF62-BE30-4549-B297-EA64DFE0DCE3/TestSizeClass.app> (loaded)

Forum post:
https://forums.xamarin.com/discussion/37188/storyboards-not-being-copied-into-app
Comment 1 Alan McGovern 2015-04-16 07:08:57 UTC
This is a dupe of our private bug 29100
Comment 2 Alan McGovern 2015-04-27 04:36:06 UTC
Marking as closed as bug #29100 was fixed.

*** This bug has been marked as a duplicate of bug 29100 ***