Bug 28859 - mono: symbol lookup error: /opt/mono/lib/libmono-llvm.so.0: undefined symbol: mini_replace_type
Summary: mono: symbol lookup error: /opt/mono/lib/libmono-llvm.so.0: undefined symbol:...
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: JIT ()
Version: 3.12.0
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-04-07 14:59 UTC by Kriston Rehberg
Modified: 2015-04-07 19:09 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Kriston Rehberg 2015-04-07 14:59:11 UTC
Take any program, for example, a "Hello, world."
Compile it.
Run it without --llvm, it works.
Run it using --llvm option, receive this error:

mono: symbol lookup error: /opt/mono/lib/libmono-llvm.so.0: undefined symbol: mini_replace_type

This version of mono was built from 3.12.1 using gcc-4.8.4 and llvm version 3.6.0svn-mono-master/ce4fcec on Ubuntu 12.04 and on Ubuntu 14.10.
Mono was built using configure options --enable-llvm --enable-loadedllvm

/opt/mono/bin/mono --version
Mono JIT compiler version 3.12.1 (tarball Tue Apr  7 11:33:49 EDT 2015)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
	TLS:           __thread
	SIGSEGV:       altstack
	Notifications: epoll
	Architecture:  amd64
	Disabled:      none
	Misc:          softdebug 
	LLVM:          yes(3.6.0svn-mono-master/ce4fcec)
	GC:            sgen
Comment 1 Zoltan Varga 2015-04-07 19:09:48 UTC
--enable-loadedllvm was broken in 3.12, this is already fixed in 4.0/master. Use just --enable-llvm.