Bug 2883 - Clean doesn't clean ReferenceProjects
Summary: Clean doesn't clean ReferenceProjects
Status: NEW
Alias: None
Product: Tools
Classification: Mono
Component: xbuild ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-01-13 10:38 UTC by Ewoud Van Craeynest
Modified: 2012-01-16 15:28 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Contains 2 build files to demo the bug + A possible fix? (1001 bytes, application/zip)
2012-01-13 10:38 UTC, Ewoud Van Craeynest
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 2883 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Ewoud Van Craeynest 2012-01-13 10:38:33 UTC
Created attachment 1184 [details]
Contains 2 build files to demo the bug + A possible fix?

When using ReferenceProject elements in your project with the default Clean target from Microsoft.Common.targets, the ReferenceProjects aren't cleaned.

MSBuild does clean the ReferenceProjects.

Attached is a zip with 2 build files.
* Application.build: the one with the ProjectReference
* Dependency.build: the one that is referenced, prints a message in Clean task

Just "xbuild Application.build /t:Clean" and notice the message from Dependency.build not being printed.

Also in the zip is a fix.patch with what I used to get it going here.

Apply the patch and try again, the message will be printed.

The mono installer I used was "mono-2.10.6-gtksharp-2.12.11-win32-1"