Bug 28818 - ios build host unable to start app sometimes
Summary: ios build host unable to start app sometimes
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 3.9
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-04-06 13:55 UTC by softlion
Modified: 2015-09-28 14:15 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description softlion 2015-04-06 13:55:35 UTC
Sometimes, i have to press CTRL+F5 on visual studio multiple times until it deploys/runs correctly.

This is the log of the ios simulator when it fails:

FBApplicationProcess: Unable to create job for "com.ac" because the bundle has no executable path.
Apr  6 19:50:16 Mac-de-minimac-2.local SpringBoard[4035]: Unable to get process exit details for 'UIKitApplication:com.ac[0xbc6c]': Could not find specified service (err 113)
Apr  6 19:50:16 Mac-de-minimac-2.local SpringBoard[4035]: Unable to delete job with label UIKitApplication:com.shapr[0xbc6c]. Error: No such process
Apr  6 19:50:16 Mac-de-minimac-2.local SpringBoard[4035]: Application 'UIKitApplication:com.ac[0xbc6c]' exited for an unknown reason.
Apr  6 19:50:16 Mac-de-minimac-2.local CoreSimulatorBridge[4043]: Failed to lookup the process ID of com.ac after successful launch.  Perhaps it crashed after launch.



This is the build host log at the same time:

[06-avr.-2015 19:50:16] stdout: Starting iPhone 5s
Launching application
ERR: There was an error launching the application: Failed to lookup the process ID of com.ac after successful launch.  Perhaps it crashed after launch.

[06-avr.-2015 19:50:16] Warning: Socket 'VS log connnection' failed, a lingering socket may remain open. The socket is not connected
[06-avr.-2015 19:50:16] Finishing Output (log:writer) Thread...
[06-avr.-2015 19:50:17] Request handled in 5,132ms
[06-avr.-2015 19:50:17] Request handled in 5,525ms
[06-avr.-2015 19:50:17] Request handled in 6,203ms
Comment 1 Enzo Heredia 2015-09-28 14:15:21 UTC
we re-wrote the way that this works for stability and quality reasons, can you try our alpha release as this should resolve the problems you had been seeing here