Bug 28782 - Layout constraints priority simply not working on Visual Studio
Summary: Layout constraints priority simply not working on Visual Studio
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS Designer ()
Version: 3.9
Hardware: PC Windows
: High normal
Target Milestone: 3.11
Assignee: Jose Medrano
URL:
Depends on:
Blocks:
 
Reported: 2015-04-05 03:24 UTC by Corrado Cavalli
Modified: 2015-04-14 10:03 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Corrado Cavalli 2015-04-05 03:24:55 UTC
In Xamarin Studio when i change a contraint priority line becomes dotted, that doesn't happen in Visual Studio (lates release updated this morning) also priority value is not set.
To reproduce:
Add a button and add some constraints
Select a constraint and type a value < 1000, no dotted line.
Select another constraint, do the same and the select the previous constraint, the value you typed is not there!
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2015-04-08 18:12:26 UTC
Many thanks for the report. When I attempt to use constraint priorities on Xamarin for VS 3.9.533 and later, I also hit a problem. In my case VS crashes, so I have filed a separate bug for that (bug 28905). I suspect this bug (bug 28782) might have the same underlying cause, but I'll leave the two as separate bugs for now, until we can verify that fixing bug 28905 fully restores proper functionality of constraint priorities.
Comment 2 Alan McGovern 2015-04-10 08:01:17 UTC
Jose, can you take a look at this when 28905 is fixed. If everything works as expected when 28905 is fixed, then we can just close this.

Thanks!
Comment 4 Shruti 2015-04-14 06:06:26 UTC
I have checked this issue with master and C5 branch and observed that this issue is fixed in master branch(XVS 5.0.572)  but still exist in C5 branch(XVS 3.11.426). Detailed Observation is given below :

Master Branch : Constraint priority line becomes dotted when the priority value is less than 1000. Also value of Priority remains same as provided.
Screencast regarding same :  http://www.screencast.com/t/E0prDHjdTfaF
Environment Info : https://gist.github.com/Shruti360/af6e682c86bc2c7c231b

C5 Release Branch : VS is still getting crashed so not able to verify this issue. 
Screencast regarding same : http://www.screencast.com/t/mGe9LM52Pb
Environment Info : https://gist.github.com/Shruti360/8af0a426ae29567b9b8b
Comment 6 Shruti 2015-04-14 10:03:08 UTC
I have  checked this issue with C5 XVS 3.11.428 and observed that Constraint priority line becomes dotted when the priority value is less than 1000. Also value of Priority remains same as provided.

Screencast regarding same :  http://www.screencast.com/t/SswHuIoyM

Environment Info : https://gist.github.com/Shruti360/636773fdb8ed8cad361f

Hence, Closing this issue.