Bug 28752 - Microsoft.Bcl.Build NuGet breaks the build
Summary: Microsoft.Bcl.Build NuGet breaks the build
Status: RESOLVED DUPLICATE of bug 35323
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild ()
Version: XI 8.8.0
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
: 26605 29007 29912 30383 ()
Depends on:
Blocks:
 
Reported: 2015-04-03 15:54 UTC by Jon Goldberger [MSFT]
Modified: 2015-10-28 01:58 UTC (History)
15 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 35323

Description Jon Goldberger [MSFT] 2015-04-03 15:54:19 UTC
## Description

This is a public version of bug 27995 for tracking purposes, but I am also making it more general as bug 27995 is filed against Xamarin for Visual Studio, but I have confirmed the issue in Xamarin Studio as well. 

Basically if the companion app project references a PCL then the Plugins folder with the Watch extension does not get placed in the companion app bundle. Then when trying to deploy the Watch app, the deployment hangs with the "Waiting for debugger to connect" in the status bar and the Watch app won't launch.

I have been unable to reproduce this with a newly created project, but I was able to reproduce this in Xamarin Studio with a customer's project in Xamarin Studio. (See private comment below)
Comment 2 Jon Goldberger [MSFT] 2015-04-03 16:00:06 UTC

*** This bug has been marked as a duplicate of bug 27995 ***
Comment 4 Sebastien Pouliot 2015-04-06 17:27:51 UTC
@Jeff it sounds like the "watchapp" condition does not work under that scenario
Comment 5 derek.chan 2015-04-06 21:41:19 UTC
What's the status on this? I can't access 27995, any advice on how I can move forward?
Will it work if I create a new PCL project and migrate all my code over?
Comment 6 Jeffrey Stedfast 2015-04-07 13:24:20 UTC
I recommend removing the "Microsoft.Pcl.Build" NuGet and things will work.
Comment 7 Daniel Cazzulino 2015-04-10 17:32:43 UTC
I found the root cause for this. The given targets file is redefining GetTargetPath, which Xamarin.iOS also redefines and is key to properly build and bundle stuff across app/extension/watchapp.

The "simple" fix is to move the Xamarin.iOS targets to the bottom of the csproj. We need to implement an explicit fix in the IDEs to do this automatically on project load and after nuget package install (since NuGet in VS modifies this automatically).
Comment 8 Jeffrey Stedfast 2015-04-13 14:37:15 UTC
*** Bug 29007 has been marked as a duplicate of this bug. ***
Comment 9 Jon Goldberger [MSFT] 2015-04-23 15:19:46 UTC
Microsoft.Bcl.Build referenced from an app project breaks the build for Today Widgets also. The Today Widget extension is not bundled with the app if the iOS app project references Microsoft.Bcl.Build and a PCL.
Comment 10 Jeffrey Stedfast 2015-05-15 09:50:15 UTC
this is fixed now
Comment 11 Rolf Bjarne Kvinge [MSFT] 2015-05-25 06:21:28 UTC
*** Bug 29912 has been marked as a duplicate of this bug. ***
Comment 12 edgeric 2015-05-27 07:50:52 UTC
I am using the Beta channel with the "fix" for it, but I am still getting the exact same issue as before.
Comment 13 Jeffrey Stedfast 2015-05-28 14:37:41 UTC
*** Bug 26605 has been marked as a duplicate of this bug. ***
Comment 14 Jeffrey Stedfast 2015-05-28 14:39:42 UTC
*** Bug 30383 has been marked as a duplicate of this bug. ***
Comment 15 srobbins103 2015-08-21 08:29:32 UTC
I still see this problem with the latest stable builds:
* Xamarin Studio Version 5.9.5 (build 10)
* Xamarin.iOS Version: 8.10.4.46 (Enterprise Edition)
Removing BCL.Build fixes it still - is it possible that there is a regression?
Comment 16 david 2015-08-30 23:52:17 UTC
I see this problem too.

I'm using XS Stable 5.9.5 build 10, with Xamarin Forms 1.4.4.6392.

I am not able to remove Microsoft.Bcl.Build because other packages in my iOS project depend on it.
Comment 17 Cody Beyer (MSFT) 2015-09-27 00:08:20 UTC
This is still occur on:

=== Xamarin Studio ===

Version 5.9.7 (build 9)
Installation UUID: fe69ddf8-5edc-42a6-ac7a-fe710eb02c0e
Runtime:
	Mono 4.0.4 ((detached/cb6d6b2)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400040002

=== Xamarin.Android ===

Version: 5.1.6.7 (Business Edition)
Android SDK: /Users/codybeyer/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 7.0 (8227)
Build 7A220

=== Xamarin.iOS ===

Version: 9.0.1.20 (Business Edition)
Hash: d8e9592
Branch: master
Build date: 2015-09-18 23:22:05-0400

=== Xamarin.Mac ===

Version: 2.0.2.111 (Business Edition)

=== Build Information ===

Release ID: 509070009
Git revision: 31fa64709030b3edb971237780a452a4c69943c4
Build date: 2015-09-17 11:44:37-04
Xamarin addins: b105d33d8cd72911ff2cf3ee0b7715d37e5f19a6

=== Operating System ===

Mac OS X 10.11.0
Darwin Codys-MacBook-Pro.local 15.0.0 Darwin Kernel Version 15.0.0
    Wed Aug 26 16:57:32 PDT 2015
    root:xnu-3247.1.106~1/RELEASE_X86_64 x86_64



Using the following steps:

1. Added a new Share extension project to my solution.
2. Added a reference to the Share extension project in the main app project
3. Changed the CFBundleIdentifier to match the main app identifier + the extension name
4. Run the project in the simulator
5. Open up Safari and click the Share icon.
6. Select more.
7. Nothing happens I don’t see my app in the list
Comment 19 Brendan Zagaeski (Xamarin Team, assistant) 2015-10-28 01:58:00 UTC
I have now filed a fresh bug report that includes a minimal test case for this problem to promote a clean and accurate bug fix.

I will mark this bug as a duplicate of that new bug for bookkeeping.

*** This bug has been marked as a duplicate of bug 35323 ***