Bug 28708 - Cannot resolve dependency to assembly 'Xamarin.Forms.Platform.WP8, Version=1.3.5.0
Summary: Cannot resolve dependency to assembly 'Xamarin.Forms.Platform.WP8, Version=1....
Status: RESOLVED INVALID
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: 1.3.5
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-04-02 15:51 UTC by ntacheva
Modified: 2015-05-21 21:23 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description ntacheva 2015-04-02 15:51:48 UTC
Hi,

Upgrading from Xamarin.Forms 1.3.5.6335 to the latest (1.4.1.6349) via NuGet, we get the following error:
Cannot resolve dependency to assembly 'Xamarin.Forms.Platform.WP8, Version=1.3.5.0, Culture=neutral, PublicKeyToken=null' because it has not been preloaded. When using the ReflectionOnly APIs, dependent assemblies must be pre-loaded or loaded on demand through the ReflectionOnlyAssemblyResolve event.
This is the second time it happens, it was when updating from 1.3.1 to 1.3.2 the previous time.
Comment 1 ntacheva 2015-04-10 13:34:50 UTC
Any update on this? This is a blocking issue for us right now. Can you, please, look into it? Thank you!
Comment 2 Jason Smith [MSFT] 2015-05-21 21:23:31 UTC
You have an issue in your csproj files somewhere. Your nuget package manager failed to cleanly upgrade you.