Bug 28683 - Mac build host unable to deploy to device from VS
Summary: Mac build host unable to deploy to device from VS
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 3.9
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-04-02 08:56 UTC by softlion
Modified: 2015-09-28 14:13 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description softlion 2015-04-02 08:56:45 UTC
ios mac 8.8.2.4, build host 3.9.0.534, vs 3.9.536.0/8.8.1.0

There is no error on VS output.
The device has plenty of space.
The app deployed once 2 days ago.
Using Debug/iPhone profile.


Build host log:

[02-avr.-2015 14:49:01] Starting /Developer/MonoTouch/usr/bin/mtouch -sdkroot "/Applications/Xcode.app/Contents/Developer" --devname "Benjamin" --killdev "com.cat.gat" --launchdev "com.cat.gat" -sdk 7.1
[02-avr.-2015 14:49:01] Command [KillApplication: CommmandUrl=KillApplication] finished (240)
[02-avr.-2015 14:49:01] Request handled in 357,602ms
[02-avr.-2015 14:49:01] Request handled in 2,769ms
[02-avr.-2015 14:49:01] Request handled in 2,801ms
[02-avr.-2015 14:49:01] Request handled in 2,94ms
[02-avr.-2015 14:49:01] Request handled in 2,811ms
[02-avr.-2015 14:49:04] Request handled in 2,601ms
[02-avr.-2015 14:49:04] Request handled in 2,352ms
[02-avr.-2015 14:49:04] Request handled in 2,439ms
[02-avr.-2015 14:49:04] Request handled in 2,282ms
[02-avr.-2015 14:49:07] stdout: Please ensure your device is connected...
Connected to: Benjamin
Could not find the application 'com.cat.gat' on the device 'Benjamin'.






Device log: (iphone 4, ios 7.1)

Apr  2 14:48:59 Benjamin MobileStorageMounter[2052] <Error>: 0x3c53218c digest_disk_image: Could not open /var/run/mobile_image_mounter/2UfRPG.dmg: No such file or directory
Apr  2 14:48:59 Benjamin MobileStorageMounter[2052] <Error>: 0x3c53218c reload_mount_map: /Developer - could not create digest
Apr  2 14:48:59 Benjamin mobile_storage_proxy[2050] <Error>: 0x3c53218c handle_lookup_image: Entry 2 of 4 did not have a digest
Apr  2 14:49:01 Benjamin MobileStorageMounter[2052] <Error>: 0x3c53218c handle_mount_disk_image: A disk image of type Developer is already mounted
Apr  2 14:49:01 Benjamin kernel[0] <Debug>: AppleD1815PMUPowerSource: limiting USB input current to 400 mA
Apr  2 14:49:01 Benjamin mobile_storage_proxy[2050] <Error>: MobileStorageMount:355 Could not extract mount path from response message
Apr  2 14:49:01 Benjamin mobile_storage_proxy[2050] <Error>: 0x3c53218c handle_mount_image: Could not mount the disk image
Apr  2 14:49:01 Benjamin mobile_storage_proxy[2050] <Error>: 0x3c53218c main: Could not mount the image
Apr  2 14:49:02 Benjamin debugserver[2054] <Notice>: MS:Notice: Injecting: (null) [debugserver] (847.27)
Apr  2 14:49:02 Benjamin com.apple.debugserver-310.2[2054] <Warning>: debugserver-310.2 for armv7.
Apr  2 14:49:02 Benjamin com.apple.debugserver-310.2[2054] <Warning>: Connecting to com.apple.debugserver service...
Apr  2 14:49:04 Benjamin mobile_installation_proxy[1107] <Error>: 0x2c5000 handle_connection: Could not receive request from host.
Apr  2 14:49:04 Benjamin com.apple.debugserver-310.2[2054] <Warning>: 1 +0.000000 sec [0806/060b]: error: ::read ( 6, 0x27d9ad8c, 1024 ) => 0 err = Function not implemented (0x0000004e)
Apr  2 14:49:04 Benjamin com.apple.debugserver-310.2[2054] <Warning>: Exiting.
Apr  2 14:49:04 Benjamin mobile_installation_proxy[1107] <Error>: 0x243000 handle_connection: Could not receive request from host.
Comment 1 softlion 2015-04-02 09:04:20 UTC
A "developer" icon was on the mac desktop. I removed it. Killed/relaunched build host. Clean/rebuild/deploy from VS.
It works.
Comment 2 Enzo Heredia 2015-09-28 14:13:09 UTC
marking this one as resolved then.