Bug 28612 - build is slow for device
Summary: build is slow for device
Status: RESOLVED ANSWERED
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: XI 8.10
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-03-31 17:58 UTC by George Cook
Modified: 2015-05-28 15:05 UTC (History)
6 users (show)

Tags: NGF
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description George Cook 2015-03-31 17:58:56 UTC
any way of speeding up build times?

cycle is > 30seconds - 1 minute, and that's on a very fast mac mini with ssd drive.

build for a native ios app of same complexity in appcode/xcode is about 10 seconds.

any way of speeding this up? more caching, etc?
Comment 1 Sebastien Pouliot 2015-05-28 15:05:32 UTC
Without any data there's no direct answer to that question. Build time is relative to your application size, so 30 seconds to a minute could not normal, or very slow.

Several build options will affect the time it takes to produce a .app bundle. Some of them are discussed in this SO post [1] and you can get more details in the talk I gave to Evolve 2013 [2]. 

[1] http://stackoverflow.com/a/13964287/220643
[2] https://www.youtube.com/watch?v=BIDI2d86zTE

If you think your settings are optimal (wrt above links) and builds are still too slow then we'll need to get more details about your application (builds log and timings) to investigate.