Bug 28604 - [Android] Dismiss Master with tap on Detail
Summary: [Android] Dismiss Master with tap on Detail
Status: RESOLVED NORESPONSE
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.4.2
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Rui Marinho
URL:
Depends on:
Blocks:
 
Reported: 2015-03-31 16:08 UTC by Simon Richards
Modified: 2016-04-08 19:58 UTC (History)
5 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Simon Richards 2015-03-31 16:08:52 UTC
On android, the MasterDetailPage's Master page can be dismissed with the back button or a swipe. On iOS it is possible to dismiss it with a tap on the Detail page. Can we also have this behaviour on Android? This is with the MasterBehaviour set to Popover.
Comment 1 Rui Marinho 2015-06-22 12:59:54 UTC
We made some improvements on Android, can you try with the latest pre release 1.4.3-pre3 and see if it works better for you,

If you still have issues please report back with a simple test case so we can better understand the problem.

Thanks.
Warm Regards
Xamarin Forms Team
Comment 2 Simon Richards 2015-06-22 19:05:35 UTC
I don't yet have a simple repro but the app will not start with 1.4.3-pre3, the log is pretty big but I think the core of the problem is:

Caused by: md52ce486a14f4bcd95899665e9d932190b.JavaProxyThrowable: System.TypeLoadException: Could not load type Xamarin.Forms.Platform._MasterDetailPageRenderer, Xamarin.Forms.Platform, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null while decoding custom attribute

I'm not sure this crash is at all related to the work on this ticket but it is blocking me verifying.
Comment 3 Rui Marinho 2015-07-15 12:44:18 UTC
Hi Simon did this problem got solved with the latest 1.4.3 final version? Or 1.4.4-pre1 ?
Comment 4 Chris King 2016-04-08 19:58:39 UTC
Thank you for your bug report. As we have not received the information requested, we cannot properly triage your bug and are marking it resolved.

Warm regards,
Xamarin Forms Team