Bug 28431 - Indirect assembly reference to System.ServiceModel blocking Indie customer's Xamarin.Mac app deployment
Summary: Indirect assembly reference to System.ServiceModel blocking Indie customer's ...
Status: RESOLVED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Other ()
Version: Master
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: master
Assignee: Chris Hamons
URL:
Depends on:
Blocks:
 
Reported: 2015-03-25 19:44 UTC by janna.mclaughlin@xamarin.com
Modified: 2015-09-15 16:05 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Comment 4 Chris Hamons 2015-03-30 13:20:01 UTC
Licensing changes like this aren't going to make 2.0, too scary at this point in the game.
Comment 5 Chris Hamons 2015-03-30 14:35:51 UTC
It appears you can work around this by turning on full linking, but that's not an idea work around.
Comment 6 Chris Hamons 2015-04-27 16:50:03 UTC
And by full link, i mean don't link. ^
Comment 8 Rajneesh Kumar 2015-08-13 11:25:10 UTC
I have checked this issue with the latest master build XM 2.3.0.105 and I build the attached test sample and observed that I am successfully able to build the sample using "Indie" licence without showing any licence trigger window. Please refer the screencast for the same.

Screencast:  http://www.screencast.com/t/re6GpcLVGL8

This issue has  been fixed hence I am closing this issue.

Thanks..!

Environment Info: https://gist.github.com/Rajneesh360Logica/4f86da54ac39f5f3f217
Comment 9 Chris Hamons 2015-09-02 11:22:01 UTC
We have a customer reporting this. I'm going to have to dig and see what's going on.
Comment 11 Chris Hamons 2015-09-15 16:05:02 UTC
Should be fixed by master / da39974bb612875ca7de8a030d66002ec9bd6021. Also in C6. I messaged the customer in question, and will have them try it out when it hits Alpha.