Bug 28429 - mini-llvm.c:40:2: error: #error "The version of the mono llvm repository is too old."
Summary: mini-llvm.c:40:2: error: #error "The version of the mono llvm repository is t...
Status: RESOLVED ANSWERED
Alias: None
Product: Runtime
Classification: Mono
Component: General ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-03-25 19:05 UTC by pr0vieh
Modified: 2015-03-27 13:02 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description pr0vieh 2015-03-25 19:05:29 UTC
i get the llvm repro from https://github.com/mono/llvm.git

git checkout mono
i have test this with master too

./configure --prefix=/mono --enable-optimized --enable-targets="x86 x86_64"
make && make install

mono is at current master

./autogen.sh --prefix=/mono --enable-llvm
make && make install
  CC       libmini_la-mini-llvm.lo
mini-llvm.c:40:2: error: #error "The version of the mono llvm repository is too old."
 #error "The version of the mono llvm repository is too old."
  ^
Makefile:2350: recipe for target 'libmini_la-mini-llvm.lo' failed

this error hit always i use --enable-llvm
Comment 1 Zoltan Varga 2015-03-26 04:39:04 UTC
Use the 'master' branch of the llvm repo, the 'mono' branch is obsolete.
Comment 2 pr0vieh 2015-03-26 06:42:01 UTC
With clone https://github.com/mono/llvm.git the same
With git checkout master the same


I have test this with a clean llvm master and the same issue i see you have set in last commit MONO_API_VERSION 4 this is exist in config/llvm-config but in your change @mono you check LLVM_API_VERSION is this right ?
Comment 3 Zoltan Varga 2015-03-26 06:51:03 UTC
Yes, it is right,  MONO_API_VERSION is taken from <llvm prefix>/include/llvm/Config/llvm-config.h and defined as an LLVM_API_VERSION define when compiling mono.
Comment 4 Zoltan Varga 2015-03-27 12:03:51 UTC
--enable-llvm picks up which llvm to use from PATH, try using --with-llvm=<prefix> instead.
Comment 5 pr0vieh 2015-03-27 13:02:48 UTC
Ok this works for me thx for help

i think update the documentation is a good way to prevent new requests about this