Bug 2842 - "No gcc compiler found" after fresh install
Summary: "No gcc compiler found" after fresh install
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 5.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-01-11 07:53 UTC by arhoads76
Modified: 2013-09-13 08:27 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description arhoads76 2012-01-11 07:53:57 UTC
Building: BuildTest (Debug|iPhoneSimulator)

Building Solution BuildTest

Building: BuildTest (Debug|iPhoneSimulator)

Performing main compilation...
/Volumes/Data/Developer/MonoTouch/usr/bin/smcs /noconfig "/out:/Users/arhoads/Projects/BuildTest/BuildTest/bin/iPhoneSimulator/Debug/BuildTest.exe" "/r:/Volumes/Data/Developer/MonoTouch/usr/lib/mono/2.1/System.dll" "/r:/Volumes/Data/Developer/MonoTouch/usr/lib/mono/2.1/System.Xml.dll" "/r:/Volumes/Data/Developer/MonoTouch/usr/lib/mono/2.1/System.Core.dll" "/r:/Volumes/Data/Developer/MonoTouch/usr/lib/mono/2.1/monotouch.dll" /nologo /warn:4 /debug:+ /debug:full /optimize- /codepage:utf8 "/define:DEBUG"  /t:exe "/Users/arhoads/Projects/BuildTest/BuildTest/Main.cs" "/Users/arhoads/Projects/BuildTest/BuildTest/AppDelegate.cs" "/Users/arhoads/Projects/BuildTest/BuildTest/BuildTestViewController.cs" "/Users/arhoads/Projects/BuildTest/BuildTest/BuildTestViewController.designer.cs" 

Compiling interface definitions
/Volumes/Data/Developer/usr/bin/ibtool --errors --warnings --notices --output-format human-readable-text "/Users/arhoads/Projects/BuildTest/BuildTest/BuildTestViewController_iPhone.xib" --compile "/Users/arhoads/Projects/BuildTest/BuildTest/bin/iPhoneSimulator/Debug/BuildTest.app/BuildTestViewController_iPhone.nib" --sdk "/Volumes/Data/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.0.sdk"
/Volumes/Data/Developer/usr/bin/ibtool --errors --warnings --notices --output-format human-readable-text "/Users/arhoads/Projects/BuildTest/BuildTest/BuildTestViewController_iPad.xib" --compile "/Users/arhoads/Projects/BuildTest/BuildTest/bin/iPhoneSimulator/Debug/BuildTest.app/BuildTestViewController_iPad.nib" --sdk "/Volumes/Data/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.0.sdk"
Build complete -- 0 errors, 0 warnings

Compiling to native code
/Volumes/Data/Developer/MonoTouch/usr/bin/mtouch -v --nomanifest --nosign -sim "/Users/arhoads/Projects/BuildTest/BuildTest/bin/iPhoneSimulator/Debug/BuildTest.app" -r "/Volumes/Data/Developer/MonoTouch/usr/lib/mono/2.1/System.dll" -r "/Volumes/Data/Developer/MonoTouch/usr/lib/mono/2.1/System.Xml.dll" -r "/Volumes/Data/Developer/MonoTouch/usr/lib/mono/2.1/System.Core.dll" -r "/Volumes/Data/Developer/MonoTouch/usr/lib/mono/2.1/monotouch.dll" -debug -nolink -sdk "5.0" "/Users/arhoads/Projects/BuildTest/BuildTest/bin/iPhoneSimulator/Debug/BuildTest.exe"
No gcc compiler found!
mtouch exited with code 1

---------------------- Done ----------------------

Build: 1 error, 0 warnings
Comment 1 Sebastien Pouliot 2012-01-11 09:46:54 UTC
Recent versions of MonoDevelop should provide a --sdkroot=dir command line option that `mtouch` will use to override the default paths. I do not see it here.

What version of MonoDevelop and MonoTouch are you using ?

You can try providing it manually, in the `extra mtouch arguments`, e.g.

--sdkroot=/Volumes/Data/Developer

and see if it works.
Comment 2 arhoads76 2012-01-11 12:57:28 UTC
No difference:


Building: BuildTest (Debug|iPhoneSimulator)

Building Solution BuildTest

Building: BuildTest (Debug|iPhoneSimulator)

Performing main compilation...
/Volumes/Data/Developer/MonoTouch/usr/bin/smcs /noconfig "/out:/Users/arhoads/Projects/BuildTest/BuildTest/bin/iPhoneSimulator/Debug/BuildTest.exe" "/r:/Volumes/Data/Developer/MonoTouch/usr/lib/mono/2.1/System.dll" "/r:/Volumes/Data/Developer/MonoTouch/usr/lib/mono/2.1/System.Xml.dll" "/r:/Volumes/Data/Developer/MonoTouch/usr/lib/mono/2.1/System.Core.dll" "/r:/Volumes/Data/Developer/MonoTouch/usr/lib/mono/2.1/monotouch.dll" /nologo /warn:4 /debug:+ /debug:full /optimize- /codepage:utf8 "/define:DEBUG"  /t:exe "/Users/arhoads/Projects/BuildTest/BuildTest/Main.cs" "/Users/arhoads/Projects/BuildTest/BuildTest/AppDelegate.cs" "/Users/arhoads/Projects/BuildTest/BuildTest/BuildTestViewController.cs" "/Users/arhoads/Projects/BuildTest/BuildTest/BuildTestViewController.designer.cs" 
Build complete -- 0 errors, 0 warnings

Compiling to native code
/Volumes/Data/Developer/MonoTouch/usr/bin/mtouch -v --nomanifest --nosign -sim "/Users/arhoads/Projects/BuildTest/BuildTest/bin/iPhoneSimulator/Debug/BuildTest.app" -r "/Volumes/Data/Developer/MonoTouch/usr/lib/mono/2.1/System.dll" -r "/Volumes/Data/Developer/MonoTouch/usr/lib/mono/2.1/System.Xml.dll" -r "/Volumes/Data/Developer/MonoTouch/usr/lib/mono/2.1/System.Core.dll" -r "/Volumes/Data/Developer/MonoTouch/usr/lib/mono/2.1/monotouch.dll" -debug -nolink -sdk "5.0" --sdkroot=/Volumes/Data/Developer "/Users/arhoads/Projects/BuildTest/BuildTest/bin/iPhoneSimulator/Debug/BuildTest.exe"
No gcc compiler found!
mtouch exited with code 1

---------------------- Done ----------------------

Build: 1 error, 0 warnings
Comment 3 Sebastien Pouliot 2012-01-11 20:18:42 UTC
> What version of MonoDevelop and MonoTouch are you using ?
Comment 4 arhoads76 2012-01-11 20:25:07 UTC
Sorry, I forgot that I did an email reply on that instead of posting here.  I'm running the latest build: 5.0.4
Comment 5 arhoads76 2012-01-11 21:15:07 UTC
MonoDevelop 2.8.5
MonoTouch 5.0.8
MonoFramework 2.10.8
Comment 6 arhoads76 2012-01-11 21:15:51 UTC
(fat finger -- monotouch 5.0.4)
Comment 7 arhoads76 2012-01-11 22:44:58 UTC
Gave up and moved /Volumes/Data/Developer to /Developer and now MonoDevelop doesn't complain anymore.  The whole "SDK Locations" thing is kinda half-baked IMO.
Comment 8 Marius Ungureanu 2013-09-13 08:27:16 UTC
.