Bug 28405 - Profiler crash on startup
Summary: Profiler crash on startup
Status: VERIFIED FIXED
Alias: None
Product: Profiler
Classification: Xamarin
Component: General ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Rodrigo Moya
URL:
: 28524 ()
Depends on:
Blocks:
 
Reported: 2015-03-25 09:04 UTC by David Petrík
Modified: 2015-05-04 11:50 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description David Petrík 2015-03-25 09:04:38 UTC
GetExtension crash when parsing command line param

--target="cz.vykazprace|cz.vykazprace.TrialSplashScreen" --device-id="Android.NEXUS_S_GAPI_19_ARM"

Pipe is not allowed character and GetExtension throws exception.

ERROR [2015-03-25 10:39:51Z]: Application Dispatcher UnhandledException 
System.ArgumentException: Illegal characters in path.
   at System.IO.Path.GetExtension(String path)
   at XamarinProfiler.Windows.Utilities.ProfilerUserSettings.AddRecentItem(String item)
   at XamarinProfiler.Windows.ViewModels.MachineTargetViewModel.Initialize()
   at XamarinProfiler.Windows.MainWindow.Window_Loaded(Object sender, RoutedEventArgs e)
   at System.Windows.EventRoute.InvokeHandlersImpl(Object source, RoutedEventArgs args, Boolean reRaised)
   at System.Windows.UIElement.RaiseEventImpl(DependencyObject sender, RoutedEventArgs args)
   at MS.Internal.FrameworkObject.OnLoaded(RoutedEventArgs args)
   at System.Windows.BroadcastEventHelper.BroadcastEvent(DependencyObject root, RoutedEvent routedEvent)
   at System.Windows.BroadcastEventHelper.BroadcastLoadedEvent(Object root)
   at System.Windows.Media.MediaContext.FireLoadedPendingCallbacks()
   at System.Windows.Media.MediaContext.FireInvokeOnRenderCallbacks()
   at System.Windows.Media.MediaContext.RenderMessageHandlerCore(Object resizedCompositionTarget)
   at System.Windows.Media.MediaContext.RenderMessageHandler(Object resizedCompositionTarget)
   at System.Windows.Interop.HwndTarget.OnResize()
   at System.Windows.Interop.HwndTarget.HandleMessage(WindowMessage msg, IntPtr wparam, IntPtr lparam)
   at System.Windows.Interop.HwndSource.HwndTargetFilterMessage(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
   at MS.Win32.HwndWrapper.WndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
   at MS.Win32.HwndSubclass.DispatcherCallbackOperation(Object o)
   at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
   at MS.Internal.Threading.ExceptionFilterHelper.TryCatchWhen(Object source, Delegate method, Object args, Int32 numArgs, Delegate catchHandler)
ERROR [2015-03-25 10:39:51Z]: Domain UnhandledException 

Second problem

After invoke Profiler in menu Tools is shown message (Unable to start profiler ...) and log dir containts folowing error. This UI message is meaningless

INFO [2015-03-25 10:22:34Z]: Exception caught on StartRecording.
System.Exception: ProfileRun is trying to start a session but CreateRun method returned null ---> System.NullReferenceException: ProfilerRun returned unexpected null in SetupNewRun
   --- End of inner exception stack trace ---
Comment 1 Rodrigo Moya 2015-03-30 04:39:40 UTC
*** Bug 28524 has been marked as a duplicate of this bug. ***
Comment 2 Dominique Louis 2015-04-28 03:03:18 UTC
@David,
  this was fixed in the latest v0.13, which was released a couple of Fridays ago. Marking this as resolved.
Comment 3 Udham Singh 2015-05-04 11:50:50 UTC
I think this bug is similar to bug 28161, and I have checked this issue with XamarinProfiler.Windows.Installer.0.14-0,  XamarinProfiler.Windows.Installer.0.13-98 and  XamarinProfiler.Windows.Installer.0.14-0 observed that reported issue has been fixed. 

Hence I am closing this issue. Please feel free to re-open this issue if you will get this issue again.

Thanks!

Environment Info : 

Windows 6.2.9200.0 (64-bit)
Xamarin Studio 5.8.3 (build 1)
Microsoft .NET 4.0.30319.18449
GTK+ 2.24.22 (MS-Windows theme)
GTK# 2.12.26
Xamarin.Android 4.20.2 (Business Edition)