Bug 28384 - [iOS] Incorrect API bindings for AVCaptureConnection.AudioChannels
Summary: [iOS] Incorrect API bindings for AVCaptureConnection.AudioChannels
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: XI 8.8.0
Hardware: PC Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Alex Soto [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2015-03-24 17:10 UTC by Dominic N [MSFT]
Modified: 2015-04-07 10:48 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Dominic N [MSFT] 2015-03-24 17:10:45 UTC
## Overview

It seems like we might have a mistake in our binding for AVCaptureConnection.AudioChannels:

Apple exports the property as an array [1], but we export via a single object [2].

[1] https://developer.apple.com/library/mac/documentation/AVFoundation/Reference/AVCaptureConnection_Class/index.html#//apple_ref/occ/instp/AVCaptureConnection/audioChannels

[2] http://iosapi.xamarin.com/?link=P%3aMonoTouch.AVFoundation.AVCaptureConnection.AudioChannels
Describes an object that represents a connection between a capture input and a capture output added to a capture session.

Please let me know if there are any additional questions. Thanks!
Comment 1 Udham Singh 2015-03-25 05:10:31 UTC
I have checked this issue and observed the reported behaviour. Please refer the screencast : http://www.screencast.com/t/pUs1V4ED

Environment Info : 

=== Xamarin Studio ===

Version 5.8.2 (build 5)
Installation UUID: ce927b2a-2c07-44c5-b186-09cfdafba6dc
Runtime:
	Mono 3.12.1 ((detached/0849ec7)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312010003

=== Apple Developer Tools ===

Xcode 6.2 (6776)
Build 6C131e

=== Xamarin.iOS ===

Version: 8.8.2.2 (Business Edition)
Hash: f5d0c5e
Branch: 
Build date: 2015-03-20 06:51:49-0400

=== Build Information ===

Release ID: 508020005
Git revision: 541c06a4f6c95383333375d56fd6c23ce48cb916
Build date: 2015-03-20 09:23:08-04
Xamarin addins: 02510c4990dee3475c282b3182d588975a63ff07

=== Operating System ===

Mac OS X 10.9.5
Darwin Xamarin76s-Mac-mini.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 2 Alex Soto [MSFT] 2015-03-26 14:28:33 UTC
Hey Dominic! Thanks for reporting this.

This is fixed in maccore master 8f3030311d01ee0a9d07fe84d75cc1ac6697168a and back ported to cycle 5
Comment 3 Miguel de Icaza [MSFT] 2015-03-27 20:25:57 UTC
If the API never could have worke don the first place, perhaps we should fix the return type now.
Comment 4 Christian Giambalvo 2015-04-07 10:31:49 UTC
Hey guys,

i'm the original reporter of this bug.
I would like to know if you can tell when the fix will be released for Xamarin.iOS.

Regards
Comment 5 Sebastien Pouliot 2015-04-07 10:46:39 UTC
@Christian it's in XI 8.10 which is now in the alpha channel (and will makes it's way thru beta and stable later this month).
Comment 6 Christian Giambalvo 2015-04-07 10:48:04 UTC
ok, thanks for the update.